Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Special Characters Issue #1363

Closed
springtouchweb opened this issue Nov 15, 2017 · 3 comments

Comments

Projects
None yet
4 participants
@springtouchweb
Copy link

commented Nov 15, 2017

In the Social Meta tool of your plugin when entering an ampersand after updating the ampersand is converted to "& " that's how it would display in the social sharing card.
special-characters
home-title

@springtouchweb

This comment has been minimized.

Copy link
Author

commented Nov 15, 2017

It displays as & ... "& amp;" not "&". Github autocorrected the entity in the first report, please let me know if you have any questions.

contactashish13 added a commit to contactashish13/all-in-one-seo-pack that referenced this issue Nov 19, 2017

@contactashish13

This comment has been minimized.

Copy link
Contributor

commented Nov 19, 2017

@contactashish13 contactashish13 added this to the 2.4.4 milestone Jan 3, 2018

@wpsmort wpsmort modified the milestones: 2.4.4, 2.4.5 Jan 11, 2018

@michaeltorbert michaeltorbert modified the milestones: 2.4.5, 2.4.6 Jan 31, 2018

contactashish13 added a commit to contactashish13/all-in-one-seo-pack that referenced this issue Mar 10, 2018

contactashish13 added a commit to contactashish13/all-in-one-seo-pack that referenced this issue Mar 10, 2018

@michaeltorbert michaeltorbert modified the milestones: 2.4.6, 2.4.7 Mar 15, 2018

@wpsmort

This comment has been minimized.

Copy link
Member

commented Mar 19, 2018

@contactashish13 I tested this and it works in that it corrects the OG meta output in the source code. Is it possible to correct the title and description displayed in the fields under Social Meta > Home Page Settings as well? The screenshot below shows that we still display the & and not the & symbol.

screen shot 2018-03-19 at 6 10 50 pm

@wpsmort wpsmort modified the milestones: 2.4.7, 2.5 Mar 20, 2018

@wpsmort wpsmort assigned contactashish13 and unassigned wpsmort Mar 22, 2018

@michaeltorbert michaeltorbert modified the milestones: 2.5, Future Release Mar 22, 2018

contactashish13 added a commit to contactashish13/all-in-one-seo-pack that referenced this issue Jul 28, 2018

contactashish13 added a commit to contactashish13/all-in-one-seo-pack that referenced this issue Sep 26, 2018

@michaeltorbert michaeltorbert modified the milestones: Future Release, 2.9 Oct 9, 2018

contactashish13 added a commit to contactashish13/all-in-one-seo-pack that referenced this issue Oct 10, 2018

contactashish13 added a commit to contactashish13/all-in-one-seo-pack that referenced this issue Oct 12, 2018

michaeltorbert added a commit that referenced this issue Oct 12, 2018

Special Characters Issue (#1372)
* Special Characters Issue #1363

* codeclimate

* test case (incomplete)

* markTestIncomplete

* PR comments

#1372 (comment)

* handle all special characters

* handle all special characters
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.