Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

noindex doesn't work when no SEO for a post type #1797

Closed
michaeltorbert opened this issue Jul 19, 2018 · 2 comments

Comments

Projects
None yet
3 participants
@michaeltorbert
Copy link
Member

commented Jul 19, 2018

While working on https://semperplugins.com/support/configuring-all-in-one-seo-pack-pro/when-to-noindex-media/, I realized that if a post type has "no seo for this post type" selected, we can't noindex it... it completely takes away the AIOSEOP section

related to #1796

@EkoJR

This comment has been minimized.

Copy link
Member

commented Sep 24, 2018

@michaeltorbert It appears that nofollow is also affected in the same way (conceptually). Should I include it here, or make a separate issue?

@michaeltorbert

This comment has been minimized.

Copy link
Member Author

commented Sep 25, 2018

@EkoJR You can make a separate issue, however, depending on what we do to fix it, the fix for this issue may apply to both.

@EkoJR EkoJR added In Development and removed Initial Review labels Sep 25, 2018

michaeltorbert added a commit to EkoJR/all-in-one-seo-pack that referenced this issue Oct 8, 2018

michaeltorbert added a commit that referenced this issue Oct 8, 2018

Fix noindex not applied when SEO isn't active on post type (#1942)
* Fix noindex not applied when SEO isn't active on post type

* add comment to #1797
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.