Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Warning: “continue” targeting switch is equivalent to “break” #2129

Closed
michaeltorbert opened this issue Jan 7, 2019 · 7 comments

Comments

Projects
None yet
5 participants
@michaeltorbert
Copy link
Member

commented Jan 7, 2019

Reported here: https://wordpress.org/support/topic/warning-continue-targeting-switch-is-equivalent-to-break-3/

Warning: “continue” targeting switch is equivalent to “break”. Did you mean to use “continue 2”? in /data01/virt71886/domeenid/www.xyz.ee/wp-content/plugins/all-in-one-seo-pack/modules/aioseop_opengraph.php on line 853

@michaeltorbert

This comment has been minimized.

Copy link
Member Author

commented Jan 27, 2019

I'm bumping this to medium priority since a PR has been submitted.
@arnaudbroes Can you try and reproduce this, then assign the PR to a developer for code review?

@michaeltorbert michaeltorbert added this to the 2.11.1 milestone Jan 27, 2019

@arnaudbroes

This comment was marked as outdated.

Copy link
Contributor

commented Jan 27, 2019

@michaeltorbert I'm not able to reproduce this issue on a test site with WordPress 5.0.3, running on a web server that uses PHP 7.3.

However, after some research (https://core.trac.wordpress.org/ticket/44543), I was able to reproduce this issue (the notice disappeared after a refresh) on WordPress 4.9.8. It seems this is a WordPress Core bug that was fixed in 5.0.

I've reached out to those two users in the WordPress.org support thread and asked them to update to a version higher than 4.9.8 to see if that resolves the issue. If it does, then I'll go ahead and close this issue.

@arnaudbroes

This comment has been minimized.

Copy link
Contributor

commented Jan 27, 2019

Nevermind, I was now able to reproduce this -
image

@gfrino

This comment was marked as resolved.

Copy link

commented Jan 29, 2019

have the same problem right after installing it in ticinoweb.net

@wpsmort wpsmort modified the milestones: 2.11.1, 2.12 Jan 31, 2019

@wpsmort

This comment has been minimized.

Copy link
Member

commented Feb 7, 2019

@michaeltorbert

This comment has been minimized.

Copy link
Member Author

commented Feb 13, 2019

Reported by "sam sam" via email

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.