Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Problem in XML sitemap caused by rsquo; character #2177

Closed
media377 opened this issue Jan 31, 2019 · 18 comments

Comments

Projects
None yet
5 participants
@media377
Copy link

commented Jan 31, 2019

Hi,

I have a problem in the All in One SEO plugin generated Sitemap :

Erreur d’analyse XML : entité non définie
Emplacement : http://www.jeremy-taburchi.com/sitemap.xml
Numéro de ligne 37, Colonne 40 : image:captionDessin de presse de l&rsquo;eau sur mars</image:caption>

I tried to update everything, I changed the theme, deactivate (major) plugins, but nothing seems to fix that...

Thanks,

Jerry

@wpsmort

This comment has been minimized.

Copy link
Member

commented Jan 31, 2019

@media377 You are correct, this is caused by the use of the &rsquo; character. However, I cannot reproduce this if I use the shortcut for that character. I can reproduce this if I type the &rsquo; character out.

@arnaudbroes Can you see if you can reproduce this on Windows using the Windows shortcut listed here - http://www.rsquo.net/

@media377

This comment has been minimized.

Copy link
Author

commented Jan 31, 2019

Hi, thanks I will test this in the next hours, and come back there as soon after.

@arnaudbroes

This comment has been minimized.

Copy link
Contributor

commented Jan 31, 2019

@wpsmort I'm not able to reproduce this when I copied the ’ character. The shortcut at rsquo.net doesn't make sense to me.

@arnaudbroes arnaudbroes removed their assignment Jan 31, 2019

@wpsmort wpsmort self-assigned this Jan 31, 2019

@media377

This comment has been minimized.

Copy link
Author

commented Feb 1, 2019

Tried to change the character with its escape code but nothing changes.

@arnaudbroes

This comment has been minimized.

Copy link
Contributor

commented Feb 1, 2019

@media377 do you have a keyboard with a French layout by any chance?

@media377

This comment has been minimized.

Copy link
Author

commented Feb 1, 2019

@arnaudbroes

This comment has been minimized.

Copy link
Contributor

commented Feb 1, 2019

Yes I have !

@media377 are you able to tell me which keyboard key(s) you need to press for that character? I have an AZERTY keyboard as well, but a Belgian one. If ours doesn't support it, then I'll go ahead and order a cheap French version on Amazon.fr.

@media377

This comment has been minimized.

Copy link
Author

commented Feb 1, 2019

the ' is under the "4" number and with the "{" sign

@arnaudbroes

This comment has been minimized.

Copy link
Contributor

commented Feb 1, 2019

@media377 so I have that key as well on my AZERTY (BE), but it produces an apostrophe (&#8216;) instead of a right quotation character (&rsquo;). Can you confirm that the French layout produces an &rsquo; by default? If so, then I'll go ahead and order one.

@semperfiwebdesign semperfiwebdesign deleted a comment from media377 Feb 1, 2019

@media377

This comment has been minimized.

Copy link
Author

commented Feb 1, 2019

My keyboard produce correctly an apostrophe, and the sitemap should too ! There is a bug.

@arnaudbroes

This comment has been minimized.

Copy link
Contributor

commented Feb 1, 2019

@contactashish13 can you have a look at this? Steve mentioned that this probably also affects &lsquo; as well. In fact it could happen with anything listed here - https://www.w3.org/wiki/Common_HTML_entities_used_for_typography

@contactashish13

This comment has been minimized.

Copy link
Contributor

commented Feb 2, 2019

@arnaudbroes I cannot reproduce this. I have used MS Word to create those characters:

‘hey’ “you”

and the sitemap renders without a problem:
image

Could you paste the entire string that you generate from your keyboard?

@media377

This comment has been minimized.

Copy link
Author

commented Feb 4, 2019

Here it is :

Dessin de presse de l'eau sur mars

The concerned post is :

http://www.jeremy-taburchi.com/lecole-de-nice-et-le-chat-rose/

At the tag meta of the strip.

@arnaudbroes

This comment has been minimized.

Copy link
Contributor

commented Feb 4, 2019

@contactashish13 user has responded.

@contactashish13

This comment has been minimized.

Copy link
Contributor

commented Feb 6, 2019

@media377 unfortunately, Dessin de presse de l'eau sur mars contains the normal apostrophe and I can't see where on the page the special character is used. @arnaudbroes can you verify?

@wpsmort

This comment has been minimized.

Copy link
Member

commented Feb 6, 2019

@contactashish13 I can only reproduce this if I actually use &rsquo; typed out exactly like that. I cannot reproduce this any other way.

@contactashish13

This comment has been minimized.

Copy link
Contributor

commented Feb 7, 2019

PR #2183

I have tested with all the characters on http://www.rsquo.net/

@arnaudbroes arnaudbroes changed the title Problem in XML sitemap generated by All In One SEO Problem in XML sitemap caused by rsquo; character Feb 7, 2019

@wpsmort wpsmort added this to the 2.12 milestone Feb 12, 2019

@wpsmort

This comment has been minimized.

Copy link
Member

commented Feb 18, 2019

Reported again by Josh Broughton by email today. This report was for the character &trade;. I confirmed this is fixed in the PR.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.