Skip to content


Subversion checkout URL

You can clone with
Download ZIP


npm install connect = error w/ node > 0.5.4 #361

ghost opened this Issue · 4 comments

2 participants


Connect can't be installed anymore w/ current version of node.

Here is the output on npm install connect.

npm install connect
npm ERR! Unsupported
npm ERR! Not compatible with your version of node/npm: connect@1.7.0
npm ERR! Required: {"node":">= 0.4.1 < 0.5.0"}
npm ERR! Actual: {"npm":"1.0.17","node":"v0.5.4"}
npm ERR!
npm ERR! System Darwin 10.8.0
npm ERR! command "node" "/usr/bin/npm" "install" "connect"
npm ERR! cwd /Users/
npm ERR! node -v v0.5.4
npm ERR! npm -v 1.0.17
npm ERR!
npm ERR! Additional logging details can be found in:
npm ERR! npm-debug.log
npm not ok


0.5.x is not supported


Will updates to current and newer versions of node be supported at some point?

Otherwise I have to deprecate use of connect and start converting to something else.

tj commented

0.5.x is not really the "current" releases of node, these are unstable releases... 0.6.0 will be the next stable

@tj tj closed this

@puppetMaster3 what TJ was trying to say is that express 3.x should be working stably with 0.6.x within some delta after 0.6 is released.

@visionmedia what's a sensible delta?

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.