Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

emacs-jabber repository not available anymore #164

Closed
tonini opened this Issue Oct 7, 2012 · 3 comments

Comments

Projects
None yet
3 participants
Collaborator

tonini commented Oct 7, 2012

I tried to update the submodules and realized that the emacs-jabber repository isn't available anymore.

=> https://github.com/Abrahanfer/emacs-jabber.git

Owner

senny commented Oct 7, 2012

@jone is this the same repository? https://github.com/demyanrogozhin/emacs-jabber
If so, can someone submit a PR with the updated submodule?

Collaborator

jone commented Oct 7, 2012

No, it is not the same, at least not the same version, and will not just work.

The "official" emacs-jabber needs running configure / make when installing. I don't think that we'll be using vendors which require additional installation steps.
The repository we used before (Abrahanfer version) did work with only checking it out.
So using an official / new version with submodules is not an option.

We could:

  1. Remove the jabber bundle and vendors. Those cabbage-users who still need to use jabber would then have to create a private bundle in ~/.emacs.d or install jabber in a different way. All support is dropped immediately.

  2. I could add a github repository and push the missing repository and change the submodule config. I still have the missing repository. It would be (and was not) the official version though.

Not sure if there is anyone actually using it beside me, so in order to clean up the cabbage bundles (#158) I propose 1) and removing it completely. Any objections? @senny ?

Owner

senny commented Oct 7, 2012

I don't use it so your suggestion is ok for me. I think you should announce it on the mailing list though.

@jone jone closed this in f5721ff Oct 8, 2012

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment