Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Really slow Editor on 20-th frame #424

Open
as3mbus opened this Issue Mar 4, 2018 · 8 comments

Comments

Projects
None yet
4 participants
@as3mbus
Copy link

as3mbus commented Mar 4, 2018

Summary of your problem or feature request

i'm having huge pause every time i move, scale, rotate the camera on sozi editor, (is it possible that it caused by imported image with link ?)

Version of Sozi and other relevant software

  • Which version of Sozi are you using? 18.01 Linux 64 bit tar package
  • Which drawing software did you use? (Inkscape 0.92.2
  • On which platform? Arch Linux 64 Bit
  • If your problem happens when playing a presentation, which browsers have you tried? nope. but played on firefox fine (Firefox Nightly 60.0.a1)

Steps to reproduce the problem

  1. create inkscape file with quite many many imported image using link method
  2. run sozi
  3. create simple frame which transistion is only move, zoom and crop
  4. it getting slower on every frame i made, on 20th~ frame it take a few second to somewhat reload (it feels like sozi freeze for a moment) after moving, zooming, the camera.
  5. i ended up waiting for 5+ sec after 30~frames.
  6. tested to play the presentation on firefox plays fine and smooth

Expected behavior

response faster after every camera navigation

Observed behavior

several second delay after every navigation

Hints and solutions (optional)

it might be caused by linked image ?
if it is, it might be good to mention that in the page.....

@as3mbus as3mbus changed the title Really slow on 20-th frame Really slow Editor on 20-th frame Mar 4, 2018

@senshu

This comment has been minimized.

Copy link
Owner

senshu commented Mar 9, 2018

tested to play the presentation on firefox plays fine and smooth

This is interesting. The editor and player use the same code, so I would expect similar issues with Firefox. Since the editor is based on Chromium, it would be useful to check whether the presentations plays smoothly in Chromium or Chrome as well.

What is the size of the images?
Do you observe similar issues if the images are not linked, but embedded in the SVG?

@as3mbus

This comment has been minimized.

Copy link
Author

as3mbus commented Mar 11, 2018

What is the size of the images?

around 100-200kb each
and there are around 10 -15 image.

Do you observe similar issues if the images are not linked, but embedded in the SVG?

havent tested yet

additional information

https://github.com/as3mbus/Linux_Desktop
this is the presentation file including images.
i'll try to mess around with chrome and stuff later

@Ekinoks

This comment has been minimized.

Copy link

Ekinoks commented Feb 11, 2019

I have exactly the same problem, if the presentation have too many frames, then after each move or resize Sozi freeze during 5-10 sec.

@senshu

This comment has been minimized.

Copy link
Owner

senshu commented Feb 12, 2019

@Ekinoks Can you, please, try Sozi 18.11 from https://drive.google.com/drive/folders/0ByRUreHgekjMWG9teGM2dE8wck0 and tell me if it works better in your case?

@Ekinoks

This comment has been minimized.

Copy link

Ekinoks commented Feb 12, 2019

@senshu It may be a little better with version 18.11.25 but I still have freezes of several seconds.
It is as if after applying a movement, the software rewrites all the code causing the freeze.
PS: I forgot to say, I'm on Windows

@h4de5

This comment has been minimized.

Copy link

h4de5 commented Mar 5, 2019

Same here - i am on current nightly - 18.11.25
I am using images that have several MBs also linked. also note, that the moving/resizing of the layers itself is running smoothly, but as soon as i release that layer or stop resizing it, it freezes for like 5 seconds.

/edit: i just changed all images to embedded and the issue persists.
/edit2: I noticed that after each move/resize, sozi is reading and writing data to the harddisk. But a lot less, as it does when actually saving. Therefor I tried changing the options for Saving and Loading from "when Sozi loses focus" to "manually" - but it did not help.
/edit3: I am also on windows.

/edit4: ffs ... I just restarted sozi and now it's working fine. I can move layers and resize them without any interruptions. Now I can't say if it's because of linked vs embedded images or if was the saving options that may have only worked after the restart. The CPU usage as well as the read and write access to the harddisk is still there after each movement - but it no longer freezes.

@senshu

This comment has been minimized.

Copy link
Owner

senshu commented Mar 6, 2019

@h4de5 The issue is difficult to reproduce. I think that it happens when you change the SVG multiple times while it is open in Sozi. Usually, when it becomes unusable, a workaround is to close Sozi and reopen it.

I have just pushed a fix for a problem that could be related to this issue. See commit 037fe90
I will upload a new test release tonight, please check the Sozi nightly builds folder. The new version number will be 19.03.

@h4de5

This comment has been minimized.

Copy link

h4de5 commented Mar 11, 2019

I can confirm that this issue comes from changing the svg outside of sozi while it has it open.
i worked now for several hours with normals saves and moves .. and it did not occure again.

will try out the new version soon.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.