Skip to content
Browse files

Bootstrap: Use most recent version of OpenSSL

  • Loading branch information
Darkspirit committed May 15, 2019
1 parent 715f9c6 commit 19a1a5f44d4483197b7c9a95753bb3c2cd2b122a
Showing with 2 additions and 15 deletions.
  1. +1 −2
  2. +1 −13 python/servo/
@@ -90,13 +90,12 @@ If this doesn't work, file a bug, and, run the commands below:
sudo apt install git curl autoconf libx11-dev \
libfreetype6-dev libgl1-mesa-dri libglib2.0-dev xorg-dev \
gperf g++ build-essential cmake virtualenv python-pip \
libssl1.0-dev libbz2-dev liblzma-dev libosmesa6-dev libxmu6 libxmu-dev \
libssl-dev libbz2-dev liblzma-dev libosmesa6-dev libxmu6 libxmu-dev \
libglu1-mesa-dev libgles2-mesa-dev libegl1-mesa-dev libdbus-1-dev \
libharfbuzz-dev ccache clang libunwind-dev \
libgstreamer1.0-dev libgstreamer-plugins-base1.0-dev libgstreamer-plugins-bad1.0-dev autoconf2.13

If you using a version prior to **Ubuntu 17.04**, **Linux Mint 19** or **Debian Sid**, replace `libssl1.0-dev` with `libssl-dev`.
Additionally, you'll need a local copy of GStreamer with a version later than 12.0. You can place it in `support/linux/gstreamer/gstreamer`, or run `./mach bootstrap-gstreamer` to set it up.

If you are using **Ubuntu 16.04** or **Linux Mint 18.*** run `export HARFBUZZ_SYS_NO_PKG_CONFIG=1` before building to avoid an error with harfbuzz.
@@ -110,7 +110,7 @@ def linux(context, force=False):
# Please keep these in sync with the packages in
pkgs_apt = ['git', 'curl', 'autoconf', 'libx11-dev', 'libfreetype6-dev',
'libgl1-mesa-dri', 'libglib2.0-dev', 'xorg-dev', 'gperf', 'g++',
'build-essential', 'cmake', 'python-pip',
'build-essential', 'cmake', 'python-pip', "libssl-dev",
'libbz2-dev', 'liblzma-dev',
'libosmesa6-dev', 'libxmu6', 'libxmu-dev', 'libglu1-mesa-dev',
'libgles2-mesa-dev', 'libegl1-mesa-dev', 'libdbus-1-dev', 'libharfbuzz-dev',
@@ -124,25 +124,13 @@ def linux(context, force=False):
'ccache', 'mesa-libGLU-devel', 'clang', 'clang-libs', 'gstreamer1-devel',
'gstreamer1-plugins-base-devel', 'gstreamer1-plugins-bad-free-devel', 'autoconf213']
if context.distro == "Ubuntu":
if context.distro_version in ["17.04", "19.04"]:
pkgs_apt += ["libssl-dev"]
elif int(context.distro_version.split(".")[0]) < 17:
pkgs_apt += ["libssl-dev"]
pkgs_apt += ["libssl1.0-dev"]

if context.distro_version == "14.04":
pkgs_apt += ["python-virtualenv"]
pkgs_apt += ["virtualenv"]
pkgs_apt += ['libgstreamer1.0-dev', 'libgstreamer-plugins-base1.0-dev',

elif context.distro == "Debian" and context.distro_version == "Sid":
pkgs_apt += ["libssl-dev"]
pkgs_apt += ["libssl1.0-dev"]

installed_something = install_linux_deps(context, pkgs_apt, pkgs_dnf, force)

if not check_gstreamer_lib():

0 comments on commit 19a1a5f

Please sign in to comment.
You can’t perform that action at this time.