Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

is less necessary? doesn't install into jruby #22

Closed
drnic opened this Issue · 6 comments

5 participants

@drnic

Currently this project cannot be installed into JRuby due to {{less}}, which depends on {{therubyracer}} which cannot install into JRuby.

Is there an alternate dependency that supports JRuby?

Alternately, perhaps document that JRuby isn't supported?

Thanks!

@chloerei

You can use static branch

gem 'twitter-bootstrap-rails', :git => "git://github.com/seyhunak/twitter-bootstrap-rails.git", :branch => "static"

That without less.

@seyhunak
Owner

@drnic Yes it is. Twitter Bootstrap project built with Less CSS (lesscss.org).

@seyhunak seyhunak closed this
@anildigital

Does static branch add Rails generators?

For me it says

Could not find generator bootstrap:install
@seyhunak
Owner

@anildigital static branch has no generators.

@dandan

I ran into the same issue, and tried using therubyrhino instead of the rubyracer. This seems to work fine.

I've created a pull request: #269

@seyhunak
Owner

Thanks, its merged

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.