rake aborted on precompile #260

Closed
luizkowalski opened this Issue Jun 6, 2012 · 3 comments

Comments

Projects
None yet
4 participants
@luizkowalski

Hi
I updated to latest gem, cleaned the public folder and runned rake assets:precompile and the rake was aborted
This is the output

[luiz@luiz api]$ rake assets:precompile
/usr/bin/ruby /usr/bin/rake assets:precompile:all RAILS_ENV=production RAILS_GROUPS=assets
Compiled jquery.js  (1ms)  (pid 12181)
Compiled jquery_ujs.js  (0ms)  (pid 12181)
Compiled twitter/bootstrap/bootstrap-transition.js  (0ms)  (pid 12181)
Compiled twitter/bootstrap/bootstrap-alert.js  (0ms)  (pid 12181)
Compiled twitter/bootstrap/bootstrap-modal.js  (0ms)  (pid 12181)
Compiled twitter/bootstrap/bootstrap-dropdown.js  (0ms)  (pid 12181)
Compiled twitter/bootstrap/bootstrap-scrollspy.js  (0ms)  (pid 12181)
Compiled twitter/bootstrap/bootstrap-tab.js  (0ms)  (pid 12181)
Compiled twitter/bootstrap/bootstrap-tooltip.js  (0ms)  (pid 12181)
Compiled twitter/bootstrap/bootstrap-popover.js  (0ms)  (pid 12181)
Compiled twitter/bootstrap/bootstrap-button.js  (0ms)  (pid 12181)
Compiled twitter/bootstrap/bootstrap-collapse.js  (0ms)  (pid 12181)
Compiled twitter/bootstrap/bootstrap-carousel.js  (0ms)  (pid 12181)
Compiled twitter/bootstrap/bootstrap-typeahead.js  (0ms)  (pid 12181)
Compiled twitter/bootstrap.js  (90ms)  (pid 12181)
Compiled bootstrap.js  (111ms)  (pid 12181)
Compiled home.js  (0ms)  (pid 12181)
Compiled recepcao.js  (0ms)  (pid 12181)
Compiled application.js  (231ms)  (pid 12181)
Compiled bootstrap_and_overrides.css  (640ms)  (pid 12181)
Compiled home.css  (64ms)  (pid 12181)
Compiled recepcao.css  (1ms)  (pid 12181)
Compiled application.css  (768ms)  (pid 12181)
rake aborted!
Invalid CSS after "...nd-image:url(""": expected ")", was "/assets/twitter..."
  (in /home/luiz/rails_dev/api/app/assets/stylesheets/application.css)

Tasks: TOP => assets:precompile:primary
(See full trace by running task with --trace)
rake aborted!
Command failed with status (1): [/usr/bin/ruby /usr/bin/rake assets:precomp...]

Tasks: TOP => assets:precompile
@kvzb

This comment has been minimized.

Show comment
Hide comment
@kvzb

kvzb Jun 6, 2012

Hello,

I'm got a similar issue during my last deployment.

Invalid CSS after "...margin-left:0;}": expected ")", was ".icon-white{bac..."
(in /.../app/assets/stylesheets/application.css)
(sass):261

kvzb commented Jun 6, 2012

Hello,

I'm got a similar issue during my last deployment.

Invalid CSS after "...margin-left:0;}": expected ")", was ".icon-white{bac..."
(in /.../app/assets/stylesheets/application.css)
(sass):261
@mdplaya

This comment has been minimized.

Show comment
Hide comment
@mdplaya

mdplaya Jun 6, 2012

I'm on V2.0.9
Looks like sprite.less is bad on lines 25 & 31. Comment those lines out and it will compile.

OR

Change
url("@{iconSpritePath}"); to url(@iconspritepath);

url("@{iconWhiteSpritePath}"); to url(@iconwhitespritepath);

The issue is the {, }, and "

mdplaya commented Jun 6, 2012

I'm on V2.0.9
Looks like sprite.less is bad on lines 25 & 31. Comment those lines out and it will compile.

OR

Change
url("@{iconSpritePath}"); to url(@iconspritepath);

url("@{iconWhiteSpritePath}"); to url(@iconwhitespritepath);

The issue is the {, }, and "

@juno

This comment has been minimized.

Show comment
Hide comment
@juno

juno Jun 6, 2012

Contributor

@mdplaya is right.
This changes introduced by 8df7689.

That incompatible syntax pointed out in 3 months ago at twitter/bootstrap.
twbs/bootstrap@7609fd4#comments

Contributor

juno commented Jun 6, 2012

@mdplaya is right.
This changes introduced by 8df7689.

That incompatible syntax pointed out in 3 months ago at twitter/bootstrap.
twbs/bootstrap@7609fd4#comments

This issue was closed.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment