Button Group Dropdown Menu Bug #352

Closed
alfonsogarza opened this Issue Aug 29, 2012 · 9 comments

Comments

Projects
None yet
9 participants

Hello,

I just upgraded to the latest master version and I my button group dropdown menus are not working. When clicked, the menu does show up but it never hides. On the other hand, the nav bar menus are working fine.

I tried gem 'twitter-bootstrap-rails', '2.1.1' and it works fine, but when I try gem 'twitter-bootstrap-rails', :git => 'git://github.com/seyhunak/twitter-bootstrap-rails.git' it doesn't work.

Note: I tried looking for similar issues but didn't find one that matched. Some where about the menu not showing at all, while others where about dropdown menus in the nav bar. My apologies if this Issue has already been raised.

sewid commented Aug 30, 2012

Same problem here...

Contributor

michaelirey commented Aug 31, 2012

Using twitter-bootstrap-rails (2.1.3) and when nav bar is small due to small window width it, menu items turn into the drop down. This drop down works fine in Safari 6.0 on OSX. But iPhone Safari ios 5.1.1 this same drop down gets stuck in the open mode. I can browse http://twitter.github.com/bootstrap/ on my iPhone and their drop down works perfectly.

This is NOT an issue using 2.1.1
This is NOT an issue using 2.1.2
This is an issue using 2.1.3

dipth commented Sep 3, 2012

+1

iwan commented Sep 4, 2012

Same problem: the menu it never hides

+1 On Safari it never hides, on Chrome it never even opens.

Anyone figured this out?

I fixed this by ensuring that all dropdowns on the page were using 'data-target' and not href.

same problem here. In development, the button group down fails. However, after using "rake assets:precompile", the same code works in production.

Please help to fix.

This issue was closed.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment