New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

After Upgrade: 'twitter/bootstrap/bootstrap.less' wasn't found. #420

Closed
PeteMichaud opened this Issue Oct 29, 2012 · 15 comments

Comments

Projects
None yet
9 participants
@PeteMichaud

PeteMichaud commented Oct 29, 2012

I upgraded and followed the upgrade instructions, but now I can't load "bootstrap.less"? This error occurs on page load once the server is running.

I've looked in the gem itself, and I can find a bootstrap.less file in the vendor/toolkit folder but I'm not sure how that file is related or why my app can't find it. Am I doing something wrong?

By the way, after the upgrade, when I start the server (thin) it gives me this warning:

WARN: tilt autoloading 'less' in a non thread-safe way; explicit require 'less' suggested.

I don't know if that's related to this issue or not so I thought I'd mention it.

@toadkicker

This comment has been minimized.

Show comment
Hide comment
@toadkicker

toadkicker Oct 31, 2012

Contributor

Can you post your gemfile from your application?

Contributor

toadkicker commented Oct 31, 2012

Can you post your gemfile from your application?

@PeteMichaud

This comment has been minimized.

Show comment
Hide comment
@PeteMichaud

PeteMichaud Oct 31, 2012

Well the bootstrap line is line group :assets do and looks like:

gem 'twitter-bootstrap-rails', :git => 'git://github.com/seyhunak/twitter-bootstrap-rails.git'

Do you really need to see the whole gemfile?

PeteMichaud commented Oct 31, 2012

Well the bootstrap line is line group :assets do and looks like:

gem 'twitter-bootstrap-rails', :git => 'git://github.com/seyhunak/twitter-bootstrap-rails.git'

Do you really need to see the whole gemfile?

@toadkicker

This comment has been minimized.

Show comment
Hide comment
@toadkicker

toadkicker Oct 31, 2012

Contributor

Take it out of the assets group and let me know!

Contributor

toadkicker commented Oct 31, 2012

Take it out of the assets group and let me know!

@PeteMichaud

This comment has been minimized.

Show comment
Hide comment
@PeteMichaud

PeteMichaud Oct 31, 2012

I did it, then I did a bundle update and here's my error:

$ bundle exec rake assets:precompile --trace
rake aborted!
cannot load such file -- twitter/bootstrap/rails
/Users/pete/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.0/lib/bundler/runtime.rb:74:in `require'
/Users/pete/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.0/lib/bundler/runtime.rb:74:in `rescue in block in require'
/Users/pete/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.0/lib/bundler/runtime.rb:62:in `block in require'
/Users/pete/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.0/lib/bundler/runtime.rb:55:in `each'
/Users/pete/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.0/lib/bundler/runtime.rb:55:in `require'
/Users/pete/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.0/lib/bundler.rb:128:in `require'
/Users/pete/Projects/myapp/config/application.rb:8:in `<top (required)>'
/Users/pete/Projects/myapp/Rakefile:5:in `require'
/Users/pete/Projects/myapp/Rakefile:5:in `<top (required)>'
/Users/pete/.rvm/gems/ruby-1.9.3-p194@global/gems/rake-0.9.2.2/lib/rake/rake_module.rb:25:in `load'
/Users/pete/.rvm/gems/ruby-1.9.3-p194@global/gems/rake-0.9.2.2/lib/rake/rake_module.rb:25:in `load_rakefile'
/Users/pete/.rvm/gems/ruby-1.9.3-p194@global/gems/rake-0.9.2.2/lib/rake/application.rb:501:in `raw_load_rakefile'
/Users/pete/.rvm/gems/ruby-1.9.3-p194@global/gems/rake-0.9.2.2/lib/rake/application.rb:82:in `block in load_rakefile'
/Users/pete/.rvm/gems/ruby-1.9.3-p194@global/gems/rake-0.9.2.2/lib/rake/application.rb:133:in `standard_exception_handling'
/Users/pete/.rvm/gems/ruby-1.9.3-p194@global/gems/rake-0.9.2.2/lib/rake/application.rb:81:in `load_rakefile'
/Users/pete/.rvm/gems/ruby-1.9.3-p194@global/gems/rake-0.9.2.2/lib/rake/application.rb:65:in `block in run'
/Users/pete/.rvm/gems/ruby-1.9.3-p194@global/gems/rake-0.9.2.2/lib/rake/application.rb:133:in `standard_exception_handling'
/Users/pete/.rvm/gems/ruby-1.9.3-p194@global/gems/rake-0.9.2.2/lib/rake/application.rb:63:in `run'
/Users/pete/.rvm/gems/ruby-1.9.3-p194@global/gems/rake-0.9.2.2/bin/rake:33:in `<top (required)>'
/Users/pete/.rvm/gems/ruby-1.9.3-p194@global/bin/rake:19:in `load'
/Users/pete/.rvm/gems/ruby-1.9.3-p194@global/bin/rake:19:in `<main>'
/Users/pete/.rvm/gems/ruby-1.9.3-p194/bin/ruby_noexec_wrapper:14:in `eval'
/Users/pete/.rvm/gems/ruby-1.9.3-p194/bin/ruby_noexec_wrapper:14:in `<main>' 

PeteMichaud commented Oct 31, 2012

I did it, then I did a bundle update and here's my error:

$ bundle exec rake assets:precompile --trace
rake aborted!
cannot load such file -- twitter/bootstrap/rails
/Users/pete/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.0/lib/bundler/runtime.rb:74:in `require'
/Users/pete/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.0/lib/bundler/runtime.rb:74:in `rescue in block in require'
/Users/pete/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.0/lib/bundler/runtime.rb:62:in `block in require'
/Users/pete/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.0/lib/bundler/runtime.rb:55:in `each'
/Users/pete/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.0/lib/bundler/runtime.rb:55:in `require'
/Users/pete/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.0/lib/bundler.rb:128:in `require'
/Users/pete/Projects/myapp/config/application.rb:8:in `<top (required)>'
/Users/pete/Projects/myapp/Rakefile:5:in `require'
/Users/pete/Projects/myapp/Rakefile:5:in `<top (required)>'
/Users/pete/.rvm/gems/ruby-1.9.3-p194@global/gems/rake-0.9.2.2/lib/rake/rake_module.rb:25:in `load'
/Users/pete/.rvm/gems/ruby-1.9.3-p194@global/gems/rake-0.9.2.2/lib/rake/rake_module.rb:25:in `load_rakefile'
/Users/pete/.rvm/gems/ruby-1.9.3-p194@global/gems/rake-0.9.2.2/lib/rake/application.rb:501:in `raw_load_rakefile'
/Users/pete/.rvm/gems/ruby-1.9.3-p194@global/gems/rake-0.9.2.2/lib/rake/application.rb:82:in `block in load_rakefile'
/Users/pete/.rvm/gems/ruby-1.9.3-p194@global/gems/rake-0.9.2.2/lib/rake/application.rb:133:in `standard_exception_handling'
/Users/pete/.rvm/gems/ruby-1.9.3-p194@global/gems/rake-0.9.2.2/lib/rake/application.rb:81:in `load_rakefile'
/Users/pete/.rvm/gems/ruby-1.9.3-p194@global/gems/rake-0.9.2.2/lib/rake/application.rb:65:in `block in run'
/Users/pete/.rvm/gems/ruby-1.9.3-p194@global/gems/rake-0.9.2.2/lib/rake/application.rb:133:in `standard_exception_handling'
/Users/pete/.rvm/gems/ruby-1.9.3-p194@global/gems/rake-0.9.2.2/lib/rake/application.rb:63:in `run'
/Users/pete/.rvm/gems/ruby-1.9.3-p194@global/gems/rake-0.9.2.2/bin/rake:33:in `<top (required)>'
/Users/pete/.rvm/gems/ruby-1.9.3-p194@global/bin/rake:19:in `load'
/Users/pete/.rvm/gems/ruby-1.9.3-p194@global/bin/rake:19:in `<main>'
/Users/pete/.rvm/gems/ruby-1.9.3-p194/bin/ruby_noexec_wrapper:14:in `eval'
/Users/pete/.rvm/gems/ruby-1.9.3-p194/bin/ruby_noexec_wrapper:14:in `<main>' 
@simonmd

This comment has been minimized.

Show comment
Hide comment
@simonmd

simonmd Nov 2, 2012

+1 . Same error
Ruby 1.9.3-p286
Rails 3.2.9.rc1

gem 'twitter-bootstrap-rails', github: 'seyhunak/twitter-bootstrap-rails' in my Gemfile

simonmd commented Nov 2, 2012

+1 . Same error
Ruby 1.9.3-p286
Rails 3.2.9.rc1

gem 'twitter-bootstrap-rails', github: 'seyhunak/twitter-bootstrap-rails' in my Gemfile

@robbied72

This comment has been minimized.

Show comment
Hide comment
@robbied72

robbied72 Nov 2, 2012

+1 same here

robbied72 commented Nov 2, 2012

+1 same here

@Curter29

This comment has been minimized.

Show comment
Hide comment
@Curter29

Curter29 Nov 2, 2012

+1

Ruby ruby-1.9.3-p194
Rails 3.2.6
Mac OSX

gem 'twitter-bootstrap-rails', :git => 'git://github.com/seyhunak/twitter-bootstrap-rails.git'

Curter29 commented Nov 2, 2012

+1

Ruby ruby-1.9.3-p194
Rails 3.2.6
Mac OSX

gem 'twitter-bootstrap-rails', :git => 'git://github.com/seyhunak/twitter-bootstrap-rails.git'

@toadkicker

This comment has been minimized.

Show comment
Hide comment
@toadkicker

toadkicker Nov 2, 2012

Contributor

See pull #432

Contributor

toadkicker commented Nov 2, 2012

See pull #432

@Curter29

This comment has been minimized.

Show comment
Hide comment
@Curter29

Curter29 Nov 2, 2012

if add gem 'less-rails', enother error appear

add_bootstrap': undefined methodconfiguration' for Bootstrap::Rails:Module (NoMethodError)

source code for this error: "if Rails.configuration.app_generators.rails[:javascript_engine] == :coffee"

Curter29 commented Nov 2, 2012

if add gem 'less-rails', enother error appear

add_bootstrap': undefined methodconfiguration' for Bootstrap::Rails:Module (NoMethodError)

source code for this error: "if Rails.configuration.app_generators.rails[:javascript_engine] == :coffee"

@cforcey

This comment has been minimized.

Show comment
Hide comment
@cforcey

cforcey Nov 2, 2012

Solution was to explicitly require less_rails in the gemfile:

gem 'less-rails'

That cleared the errors for me without needing to remove the less require line in the short term.

cforcey commented Nov 2, 2012

Solution was to explicitly require less_rails in the gemfile:

gem 'less-rails'

That cleared the errors for me without needing to remove the less require line in the short term.

@simonmd

This comment has been minimized.

Show comment
Hide comment
@simonmd

simonmd Nov 2, 2012

The solution by @cforcey , along with 'therubyracer' works for now.

simonmd commented Nov 2, 2012

The solution by @cforcey , along with 'therubyracer' works for now.

@seyhunak

This comment has been minimized.

Show comment
Hide comment
@seyhunak

seyhunak Nov 3, 2012

Owner

@toadkicker 's fix #432 merged. I pushed new gem to Rubygems, please update your stack

Owner

seyhunak commented Nov 3, 2012

@toadkicker 's fix #432 merged. I pushed new gem to Rubygems, please update your stack

@bjoernw

This comment has been minimized.

Show comment
Hide comment
@bjoernw

bjoernw Nov 13, 2012

i had to remove gem "bootstrap-sass", ">= 2.1.0.0" to fix this issue

bjoernw commented Nov 13, 2012

i had to remove gem "bootstrap-sass", ">= 2.1.0.0" to fix this issue

@miraclecoder

This comment has been minimized.

Show comment
Hide comment
@miraclecoder

miraclecoder Nov 21, 2012

"i had to remove gem "bootstrap-sass", ">= 2.1.0.0" to fix this issue"
This also worked for me

miraclecoder commented Nov 21, 2012

"i had to remove gem "bootstrap-sass", ">= 2.1.0.0" to fix this issue"
This also worked for me

@toadkicker

This comment has been minimized.

Show comment
Hide comment
@toadkicker

toadkicker Apr 27, 2013

Contributor

Updated docs to discuss handling SASS. #561

Contributor

toadkicker commented Apr 27, 2013

Updated docs to discuss handling SASS. #561

@toadkicker toadkicker closed this Apr 27, 2013

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment