Upgrading Guide

toadkicker edited this page Sep 27, 2012 · 7 revisions

First, update your bundle via

bundle update

and run install generator

rails g bootstrap:install

So you have to require "bootstrap_and_overrides" file in your application.css.

Change the line;

*= require twitter/bootstrap 

in application.css to

*= require bootstrap_and_overrides

This file imports Bootstrap and responsive styles for you (Responsive module is separated.)

If you'd like to alter Bootstrap's own variables, or define your LESS styles inheriting Bootstrap's mixins, you can do so inside bootstrap_and_overrides.css.less:

@linkColor: #ff0000;

After upgrading

You may need to force a recompile of the less files. Make a change to bootstrap_and_overrides.css.less or touch the file and restart your server.

You may also want to bump the version number of your assets. To do this, open config/application.rb

config.assets.version = '1.0'

For detailed steps please check README file; https://github.com/seyhunak/twitter-bootstrap-rails/blob/master/README.md

Glyphicons is showing two icons

Bootstrap changed the icon classes and simplified it from <i class="icon icon-home"></i> to <i class="icon-home"></i>