Skip to content
This repository
Newer
Older
100644 54 lines (45 sloc) 1.333 kb
3d1664a0 »
2010-08-01 first commit
1 source 'http://rubygems.org'
2
9887641c »
2010-08-30 Sort
3 # Bundle gems for the local environment. Make sure to
4 # put test-only gems in this group so their generators
5 # and rake tasks are available in development mode:
6 group :development, :test do
8ab6f429 »
2011-06-16 Revert to change made by @sferik (merge issue)
7 gem 'rails', '~> 3.0.0'
3bab54d7 »
2011-07-22 Use factory_girl 2.0 final
8
ebbe21cd »
2011-05-04 Remove dynamic code from gemspec because it can only be built one way
9 platforms :jruby do
10 gem 'jruby-openssl', '~> 0.7'
ba4928c1 »
2010-12-22 Add CI's dependencies to engine's Gemfile
11 case ENV['CI_DB_ADAPTER']
df540f1e »
2011-07-30 Revert "Add mysql2 adapter"
12 when 'mysql'
e5f05ecb »
2010-12-22 Merge branch 'master' into ci
13 gem 'activerecord-jdbcmysql-adapter', '~> 1.1', :platform => :jruby
14 gem 'jdbc-mysql', '~> 5.1', :platform => :jruby
ba4928c1 »
2010-12-22 Add CI's dependencies to engine's Gemfile
15 when 'postgresql'
e5f05ecb »
2010-12-22 Merge branch 'master' into ci
16 gem 'activerecord-jdbcpostgresql-adapter', '~> 1.1', :platform => :jruby
572d5f51 »
2011-01-18 Update jdbc-postgres dependency for CI to 9.0
17 gem 'jdbc-postgres', '~> 9.0', :platform => :jruby
ba4928c1 »
2010-12-22 Add CI's dependencies to engine's Gemfile
18 else
e5f05ecb »
2010-12-22 Merge branch 'master' into ci
19 gem 'activerecord-jdbcsqlite3-adapter', '~> 1.1', :platform => :jruby
20 gem 'jdbc-sqlite3', '~> 3.6', :platform => :jruby
ba4928c1 »
2010-12-22 Add CI's dependencies to engine's Gemfile
21 end
ebbe21cd »
2011-05-04 Remove dynamic code from gemspec because it can only be built one way
22 end
23
24 platforms :ruby, :mswin, :mingw do
ba4928c1 »
2010-12-22 Add CI's dependencies to engine's Gemfile
25 case ENV['CI_DB_ADAPTER']
26 when 'mysql'
27 gem 'mysql', '~> 2.8'
28 when 'postgresql'
29 gem 'pg', '~> 0.10'
30 else
8ad0c79c »
2011-01-16 Update sqlite3 dependency to 1.3.3
31 gem 'sqlite3', '~> 1.3'
ba4928c1 »
2010-12-22 Add CI's dependencies to engine's Gemfile
32 end
de95b51c »
2010-12-02 Move JRuby dependencies into Gemfile in order to specify platform
33 end
ebbe21cd »
2011-05-04 Remove dynamic code from gemspec because it can only be built one way
34
35 gem 'cancan' if ENV['AUTHORIZATION_ADAPTER'] == 'cancan'
22f95d30 »
2011-05-13 fixed Gemfile debugger gem
36
deff628b »
2011-07-31 Don't bundle ruby-debug or linecache in the test environment
37 platform :rbx do
38 gem 'nokogiri', '1.4.7' # Nokogiri 1.5.0 is incompatible with Rubinius 1.2.3
39 end
40 end
41
42 group :development do
22f95d30 »
2011-05-13 fixed Gemfile debugger gem
43 platform :mri_18 do
44 gem 'ruby-debug'
fe4c6240 »
2011-07-24 Unlock linecache dependency now that 0.46 has been released
45 gem 'linecache'
22f95d30 »
2011-05-13 fixed Gemfile debugger gem
46 end
47
48 platform :mri_19 do
49 gem 'ruby-debug19'
50 end
352b30e4 »
2010-08-30 Cleanup
51 end
ebbe21cd »
2011-05-04 Remove dynamic code from gemspec because it can only be built one way
52
53 gemspec
Something went wrong with that request. Please try again.