Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Newer
Older
100644 79 lines (69 sloc) 2.012 kb
cf4bf69 @sferik Use HTTPS rubygems source
authored
1 source 'https://rubygems.org'
3d1664a @sferik first commit
authored
2
9887641 @sferik Sort
authored
3 # Bundle gems for the local environment. Make sure to
4 # put test-only gems in this group so their generators
5 # and rake tasks are available in development mode:
531756f @mshibuya Making ORM switchable, and test passes for ActiveRecord
mshibuya authored
6 group :active_record do
ebbe21c @sferik Remove dynamic code from gemspec because it can only be built one way
authored
7 platforms :jruby do
ba4928c @kaapa Add CI's dependencies to engine's Gemfile
kaapa authored
8 case ENV['CI_DB_ADAPTER']
9 when 'mysql'
1628f1b @sferik Update Active Record JDBC adapters to version 1.2
authored
10 gem 'activerecord-jdbcmysql-adapter', '~> 1.2'
d3b313d @sferik Cleanup trailing whitespace
authored
11 gem 'jdbc-mysql', '~> 5.1'
ba4928c @kaapa Add CI's dependencies to engine's Gemfile
kaapa authored
12 when 'postgresql'
1628f1b @sferik Update Active Record JDBC adapters to version 1.2
authored
13 gem 'activerecord-jdbcpostgresql-adapter', '~> 1.2'
8256083 @sferik Remove redundant platform specification
authored
14 gem 'jdbc-postgres', '~> 9.0'
ba4928c @kaapa Add CI's dependencies to engine's Gemfile
kaapa authored
15 else
1628f1b @sferik Update Active Record JDBC adapters to version 1.2
authored
16 gem 'activerecord-jdbcsqlite3-adapter', '~> 1.2'
8256083 @sferik Remove redundant platform specification
authored
17 gem 'jdbc-sqlite3', '~> 3.6'
ba4928c @kaapa Add CI's dependencies to engine's Gemfile
kaapa authored
18 end
ebbe21c @sferik Remove dynamic code from gemspec because it can only be built one way
authored
19 end
20
21 platforms :ruby, :mswin, :mingw do
ba4928c @kaapa Add CI's dependencies to engine's Gemfile
kaapa authored
22 case ENV['CI_DB_ADAPTER']
23 when 'mysql'
24 gem 'mysql', '~> 2.8'
25 when 'postgresql'
1164e4f @bbenezech silence postgres by removing silent-postgres.
bbenezech authored
26 gem 'pg', '~> 0.13'
ba4928c @kaapa Add CI's dependencies to engine's Gemfile
kaapa authored
27 else
8ad0c79 @sferik Update sqlite3 dependency to 1.3.3
authored
28 gem 'sqlite3', '~> 1.3'
ba4928c @kaapa Add CI's dependencies to engine's Gemfile
kaapa authored
29 end
de95b51 @sferik Move JRuby dependencies into Gemfile in order to specify platform
authored
30 end
531756f @mshibuya Making ORM switchable, and test passes for ActiveRecord
mshibuya authored
31 gem 'carrierwave'
32 end
ebbe21c @sferik Remove dynamic code from gemspec because it can only be built one way
authored
33
531756f @mshibuya Making ORM switchable, and test passes for ActiveRecord
mshibuya authored
34 group :mongoid do
2cff501 @mshibuya Add Mongoid 3.0.0 to CI matrix and address spec failures
mshibuya authored
35 case ENV['CI_ORM_VERSION']
36 when 'head'
37 gem 'mongoid', :git => 'git://github.com/mongoid/mongoid.git'
2a3b6a9 @mshibuya Keep up with the recent changes of Mongoid master. Fixes #1136
mshibuya authored
38 gem 'mongoid-paperclip', :require => 'mongoid_paperclip', :git => 'git://github.com/mshibuya/mongoid-paperclip.git', :branch => 'fix-stop-patching-logger'
082ec6c @sferik Ditto for paperclip
authored
39 # For now, carrierwave-mongoid's mongoid dependency is restricted to '~> 2.1'
2cff501 @mshibuya Add Mongoid 3.0.0 to CI matrix and address spec failures
mshibuya authored
40 gem 'carrierwave-mongoid', :require => 'carrierwave/mongoid', :git => 'git://github.com/tanordheim/carrierwave-mongoid.git', :branch => 'mongoid_3_0'
41 else
752e300 @mshibuya Attempt to fix jruby CI failure.
mshibuya authored
42 platforms :ruby, :mswin, :mingw do
db6b852 @sferik Unlock bson dependency
authored
43 gem 'bson'
752e300 @mshibuya Attempt to fix jruby CI failure.
mshibuya authored
44 gem 'bson_ext'
45 end
2cff501 @mshibuya Add Mongoid 3.0.0 to CI matrix and address spec failures
mshibuya authored
46 gem 'mongoid'
2a3b6a9 @mshibuya Keep up with the recent changes of Mongoid master. Fixes #1136
mshibuya authored
47 gem 'mongoid-paperclip', :require => 'mongoid_paperclip'
2cff501 @mshibuya Add Mongoid 3.0.0 to CI matrix and address spec failures
mshibuya authored
48 gem 'carrierwave-mongoid', :require => 'carrierwave/mongoid'
49 end
531756f @mshibuya Making ORM switchable, and test passes for ActiveRecord
mshibuya authored
50 end
51
b498f72 @sferik Rename debug group
authored
52 group :debug do
22f95d3 @crosebrugh fixed Gemfile debugger gem
crosebrugh authored
53 platform :mri_18 do
54 gem 'ruby-debug'
3742e4f @sferik Revert "linecache 0.46 depends on rbx-require-relative, which require…
authored
55 gem 'linecache'
22f95d3 @crosebrugh fixed Gemfile debugger gem
crosebrugh authored
56 end
57
58 platform :mri_19 do
59 gem 'ruby-debug19'
5c4e6eb @mshibuya Changed SimpleCov dependency to be included only in mri_19
mshibuya authored
60 gem 'simplecov', :require => false
22f95d3 @crosebrugh fixed Gemfile debugger gem
crosebrugh authored
61 end
d5de040 @mshibuya Freeze Paperclip's version to 2.x because of incompatibility with jru…
mshibuya authored
62
63 platform :jruby do
64 gem 'ruby-debug'
65 end
352b30e @sferik Cleanup
authored
66 end
ebbe21c @sferik Remove dynamic code from gemspec because it can only be built one way
authored
67
2b0e1a2 @sferik FasterCSV required on Windows and JRuby in 1.8 mode
authored
68 platforms :jruby, :mingw_18, :ruby_18 do
849898f @sferik Loosen gem dependencies
authored
69 gem 'fastercsv', '~> 1.5'
440213a @sferik Remove fastercsv from gemspec, since it won't install on the Heroku c…
authored
70 end
71
1a3969b @sferik Add back development/test group
authored
72 group :development, :test do
73 gem 'cancan'
9bfa8c9 @mshibuya Change JRuby CI matrix to jruby-19mode. refs #1078
mshibuya authored
74 gem 'devise'
a764ed6 @mshibuya Revert "Upgrade Paperclip dependency"
mshibuya authored
75 gem 'paperclip', '~> 2.7'
1a3969b @sferik Add back development/test group
authored
76 end
77
ebbe21c @sferik Remove dynamic code from gemspec because it can only be built one way
authored
78 gemspec
Something went wrong with that request. Please try again.