Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

Update simplecov dependency to >= 0.9

  • Loading branch information...
commit 170fa354fa3ac8f02cc8a999a0499e12af8947ee 1 parent e7be525
@sferik authored
Showing with 33 additions and 34 deletions.
  1. +28 −26 .travis.yml
  2. +3 −3 Gemfile
  3. +2 −5 spec/spec_helper.rb
View
54 .travis.yml
@@ -1,21 +1,5 @@
language: ruby
-rvm:
- - 1.9.3
- - 2.0.0
- - 2.1.1
- - rbx-2
- - ruby-head
-
-services:
- - mongodb
-
-bundler_args: --without development --jobs=3 --retry=3
-
-sudo: false
-
-cache: bundler
-
before_script:
- cd spec/dummy_app
- bundle install
@@ -23,28 +7,46 @@ before_script:
- bundle exec rake db:create db:migrate
- cd ../../
+bundler_args: --without development --jobs=3 --retry=3
+
+cache: bundler
+
env:
- CI_ORM=mongoid
- CI_ORM=active_record CI_DB_ADAPTER=sqlite3
+ global:
+ - JRUBY_OPTS="$JRUBY_OPTS --debug"
+
+rvm:
+ - 1.9.3
+ - 2.0.0
+ - 2.1
+ - rbx-2
+ - ruby-head
+
+services:
+ - mongodb
+
+sudo: false
matrix:
include:
- - rvm: 2.1.1
+ - rvm: 2.1
env: CI_ORM=active_record CI_DB_ADAPTER=mysql2
- - rvm: 2.1.1
+ - rvm: 2.1
env: CI_ORM=active_record CI_DB_ADAPTER=postgresql CI_DB_USERNAME=postgres
- - rvm: 2.1.1
- env: RAILS_VER=4.0 CI_ORM=active_record CI_DB_ADAPTER=sqlite3
- - rvm: 2.1.1
- env: RAILS_VER=4.0 CI_ORM=mongoid
+ - rvm: 2.1
+ env: RAILS_VERSION=4.0 CI_ORM=active_record CI_DB_ADAPTER=sqlite3
+ - rvm: 2.1
+ env: RAILS_VERSION=4.0 CI_ORM=mongoid
- rvm: jruby-19mode
- env: CI_ORM=mongoid JRUBY_OPTS="$JRUBY_OPTS --debug"
+ env: CI_ORM=mongoid
- rvm: jruby-19mode
- env: CI_ORM=active_record CI_DB_ADAPTER=sqlite3 JRUBY_OPTS="$JRUBY_OPTS --debug"
+ env: CI_ORM=active_record CI_DB_ADAPTER=sqlite3
- rvm: jruby-head
- env: CI_ORM=mongoid JRUBY_OPTS="$JRUBY_OPTS --debug"
+ env: CI_ORM=mongoid
- rvm: jruby-head
- env: CI_ORM=active_record CI_DB_ADAPTER=sqlite3 JRUBY_OPTS="$JRUBY_OPTS --debug"
+ env: CI_ORM=active_record CI_DB_ADAPTER=sqlite3
allow_failures:
- rvm: jruby-head
- rvm: rbx-2
View
6 Gemfile
@@ -1,6 +1,6 @@
source 'https://rubygems.org'
-case ENV['RAILS_VER']
+case ENV['RAILS_VERSION']
when '4.0'
gem 'rails', '~> 4.0.0'
else
@@ -52,7 +52,7 @@ group :test do
gem 'cancan', '>= 1.6'
gem 'capybara', '>= 2.1'
gem 'carrierwave', '>= 0.8'
- gem 'coveralls', require: false
+ gem 'coveralls'
gem 'database_cleaner', '>= 1.2'
gem 'devise', '>= 3.2'
gem 'dragonfly', '~> 1.0'
@@ -65,7 +65,7 @@ group :test do
gem 'rack-cache', require: 'rack/cache'
gem 'rspec-rails', '>= 2.14'
gem 'rubocop', '>= 0.19.0'
- gem 'simplecov', require: false
+ gem 'simplecov', '>= 0.9'
gem 'timecop', '>= 0.5'
end
View
7 spec/spec_helper.rb
@@ -7,14 +7,11 @@
require 'simplecov'
require 'coveralls'
-SimpleCov.formatter = SimpleCov::Formatter::MultiFormatter[ # rubocop:disable SpaceBeforeFirstArg
- SimpleCov::Formatter::HTMLFormatter,
- Coveralls::SimpleCov::Formatter
-]
+SimpleCov.formatters = [SimpleCov::Formatter::HTMLFormatter, Coveralls::SimpleCov::Formatter]
SimpleCov.start do
add_filter '/spec/'
- minimum_coverage(91.71) unless defined? JRUBY_VERSION
+ minimum_coverage(91.71)
end
require File.expand_path('../dummy_app/config/environment', __FILE__)
Please sign in to comment.
Something went wrong with that request. Please try again.