Permalink
Browse files

Use factory_girl 2.0 final

Move dependency into gemspec
  • Loading branch information...
1 parent c5ebd1c commit 3bab54d76247e2f38cc93b6f2b4cd2cf60246fb4 @sferik committed Jul 22, 2011
Showing with 5 additions and 5 deletions.
  1. +1 −3 Gemfile
  2. +4 −2 rails_admin.gemspec
View
4 Gemfile
@@ -5,7 +5,7 @@ source 'http://rubygems.org'
# and rake tasks are available in development mode:
group :development, :test do
gem 'rails', '~> 3.0.0'
-
+
platforms :jruby do
gem 'jruby-openssl', '~> 0.7'
case ENV['CI_DB_ADAPTER']
@@ -33,8 +33,6 @@ group :development, :test do
end
gem 'cancan' if ENV['AUTHORIZATION_ADAPTER'] == 'cancan'
- gem 'factory_girl', '2.0.0.beta2'
- gem 'generator_spec'
platform :mri_18 do
gem 'ruby-debug'
View
6 rails_admin.gemspec
@@ -2,9 +2,11 @@
Gem::Specification.new do |gem|
# If you add a dependency, please maintain alphabetical order
- gem.add_development_dependency 'capybara', '~> 1.0.0'
+ gem.add_development_dependency 'capybara', '~> 1.0'
gem.add_development_dependency 'devise', '~> 1.1'
gem.add_development_dependency 'dummy_data', '~> 0.9'
+ gem.add_development_dependency 'factory_girl', '~> 2.0'
+ gem.add_development_dependency 'generator_spec', '~> 0.8'
gem.add_development_dependency 'maruku', '~> 0.6'
gem.add_development_dependency 'paperclip', '~> 2.3'
gem.add_development_dependency 'rspec-rails', '~> 2.6'
@@ -13,7 +15,7 @@ Gem::Specification.new do |gem|
gem.add_development_dependency 'ZenTest', '~> 4.5'
gem.add_runtime_dependency 'builder', '~> 2.1.0'
- gem.add_runtime_dependency 'fastercsv'
+ gem.add_runtime_dependency 'fastercsv', '~> 1.5.4'
gem.add_runtime_dependency 'haml', ['>= 3.1.0', '< 3.3.0']
gem.add_runtime_dependency 'rails', '~> 3.0.9'

0 comments on commit 3bab54d

Please sign in to comment.