Skip to content
Browse files

add jruby

  • Loading branch information...
1 parent 1d19bf5 commit 854754bdb734f39f264f713e6e46f6207dfd10eb @bbenezech bbenezech committed Feb 21, 2012
Showing with 26 additions and 16 deletions.
  1. +25 −12 .travis.yml
  2. +1 −4 Gemfile
View
37 .travis.yml
@@ -5,6 +5,7 @@ rvm:
- 1.9.3
- rbx
- ree
+ - jruby
env:
- "CI_DB_ADAPTER=sqlite3"
- "CI_DB_ADAPTER=postgresql CI_DB_USERNAME=postgres"
@@ -28,6 +29,9 @@ matrix:
- rvm: ree
env: "CI_DB_ADAPTER=postgresql CI_DB_USERNAME=postgres"
gemfile: Gemfile31
+ - rvm: ree
+ gemfile: Gemfile31
+ env: "CI_DB_ADAPTER=mysql"
- rvm: rbx
env: "CI_DB_ADAPTER=sqlite3"
@@ -41,23 +45,32 @@ matrix:
- rvm: rbx
env: "CI_DB_ADAPTER=postgresql CI_DB_USERNAME=postgres"
gemfile: Gemfile31
-
- - rvm: 1.9.3
+ - rvm: rbx
env: "CI_DB_ADAPTER=mysql"
+ gemfile: Gemfile31
+
+ - rvm: jruby
+ env: "CI_DB_ADAPTER=sqlite3"
gemfile: Gemfile
- - rvm: 1.9.3
+ - rvm: jruby
+ env: "CI_DB_ADAPTER=sqlite3"
+ gemfile: Gemfile31
+ - rvm: jruby
+ env: "CI_DB_ADAPTER=postgresql CI_DB_USERNAME=postgres"
+ gemfile: Gemfile
+ - rvm: jruby
+ env: "CI_DB_ADAPTER=postgresql CI_DB_USERNAME=postgres"
+ gemfile: Gemfile31
+ - rvm: jruby
env: "CI_DB_ADAPTER=mysql"
gemfile: Gemfile31
- - gemfile: Gemfile31
- rvm: ree
+ - rvm: 1.9.3
env: "CI_DB_ADAPTER=mysql"
-
- - gemfile: Gemfile31
- rvm: rbx
+ gemfile: Gemfile
+ - rvm: 1.9.3
env: "CI_DB_ADAPTER=mysql"
-
- - gemfile: Gemfile31
- rvm: 1.9.3
+ gemfile: Gemfile31
+ - rvm: 1.9.3
+ gemfile: Gemfile31
env: "CI_DB_ADAPTER=postgresql CI_DB_USERNAME=postgres"
-
View
5 Gemfile
@@ -8,13 +8,10 @@ group :development, :test do
gem 'rails_admin_custom_field', :git => 'git://github.com/bbenezech/rails_admin_custom_field.git'
platforms :jruby do
- gem 'jruby-openssl', '~> 0.7'
- # activerecord-jdbc-adapter does not yet have a rails 3.1 compatible release
- gem 'activerecord-jdbc-adapter', :git => 'git://github.com/jruby/activerecord-jdbc-adapter.git'
case ENV['CI_DB_ADAPTER']
when 'mysql'
gem 'activerecord-jdbcmysql-adapter', '~> 1.2'
- gem 'jdbc-mysql', '~> 5.1'
+ gem 'jdbc-mysql', '~> 5.1'
when 'postgresql'
gem 'activerecord-jdbcpostgresql-adapter', '~> 1.2'
gem 'jdbc-postgres', '~> 9.0'

0 comments on commit 854754b

Please sign in to comment.
Something went wrong with that request. Please try again.