Browse files

Infer dependencies from the gemspec

  • Loading branch information...
1 parent 49a13a6 commit d238530eeb8d2f2503a0f6b58e1adfa4ec9dce66 @sferik committed Sep 12, 2010
Showing with 19 additions and 15 deletions.
  1. +1 −6 Gemfile
  2. +15 −6 Gemfile.lock
  3. +3 −3 rails_admin.gemspec
View
7 Gemfile
@@ -1,15 +1,10 @@
source 'http://rubygems.org'
-gem 'rails', '3.0.0'
-gem 'builder'
-gem 'devise'
+gemspec
# Bundle gems for the local environment. Make sure to
# put test-only gems in this group so their generators
# and rake tasks are available in development mode:
group :development, :test do
- gem 'dummy_data'
- gem 'rspec-rails', '>= 2.0.0.beta.20'
- gem 'sqlite3-ruby', :require => 'sqlite3'
gem 'webrat', :git => 'git://github.com/kalv/webrat.git'
end
View
21 Gemfile.lock
@@ -7,6 +7,14 @@ GIT
rack (>= 1.0)
rack-test (>= 0.5.3)
+PATH
+ remote: .
+ specs:
+ rails_admin (0.0.1)
+ builder (~> 2.1.0)
+ devise (~> 1.1.0)
+ rails (~> 3.0.0)
+
GEM
remote: http://rubygems.org/
specs:
@@ -102,10 +110,11 @@ PLATFORMS
ruby
DEPENDENCIES
- builder
- devise
- dummy_data
- rails (= 3.0.0)
- rspec-rails (>= 2.0.0.beta.20)
- sqlite3-ruby
+ builder (~> 2.1.0)
+ devise (~> 1.1.0)
+ dummy_data (~> 0.9)
+ rails (~> 3.0.0)
+ rails_admin!
+ rspec-rails (~> 2.0.0.beta.22)
+ sqlite3-ruby (~> 1.3)
webrat!
View
6 rails_admin.gemspec
@@ -2,9 +2,9 @@
require File.expand_path("../lib/rails_admin/version", __FILE__)
Gem::Specification.new do |s|
- s.add_development_dependency("dummy_data", [">= 0.9"])
- s.add_development_dependency("rspec-rails", [">= 2.0.0.beta.20"])
- s.add_development_dependency("sqlite3-ruby", [">= 1.3.1"])
+ s.add_development_dependency("dummy_data", ["~> 0.9"])
+ s.add_development_dependency("rspec-rails", ["~> 2.0.0.beta.22"])
+ s.add_development_dependency("sqlite3-ruby", ["~> 1.3"])
s.add_runtime_dependency("builder", ["~> 2.1.0"])
s.add_runtime_dependency("devise", ["~> 1.1.0"])
s.add_runtime_dependency("rails", ["~> 3.0.0"])

0 comments on commit d238530

Please sign in to comment.