bootstrap-wysihtml5-rails double toolbar #1296

Closed
lamguy opened this Issue Aug 26, 2012 · 5 comments

Comments

Projects
None yet
4 participants
@lamguy

lamguy commented Aug 26, 2012

Hello,

After trying to re-compile the assets of development mode, the toolbar of the editor was doubled.

See screenshot: http://cl.ly/image/250A2n331V08

Anyone has addressed this issue before?

@dexion

This comment has been minimized.

Show comment
Hide comment
@dexion

dexion Aug 28, 2012

Contributor

read more about dev\production.
You have duplicate files

Contributor

dexion commented Aug 28, 2012

read more about dev\production.
You have duplicate files

@brewster1134

This comment has been minimized.

Show comment
Hide comment
@brewster1134

brewster1134 Sep 18, 2012

Contributor

i submit a pull request that will likely solve this issue...

#1324

Contributor

brewster1134 commented Sep 18, 2012

i submit a pull request that will likely solve this issue...

#1324

@mshibuya

This comment has been minimized.

Show comment
Hide comment
@mshibuya

mshibuya Sep 19, 2012

Collaborator

Please do not precompile assets in dev environment. That will lead to duplication of initialization process and bootstrap-wysihtml5-all.js to be loaded twice.
Do it on deployment instead.

Collaborator

mshibuya commented Sep 19, 2012

Please do not precompile assets in dev environment. That will lead to duplication of initialization process and bootstrap-wysihtml5-all.js to be loaded twice.
Do it on deployment instead.

@mshibuya mshibuya closed this Sep 19, 2012

@brewster1134

This comment has been minimized.

Show comment
Hide comment
@brewster1134

brewster1134 Sep 19, 2012

Contributor

the pull request i submit should solve that problem and allow for validating asset precompilation in development.

Contributor

brewster1134 commented Sep 19, 2012

the pull request i submit should solve that problem and allow for validating asset precompilation in development.

@mshibuya

This comment has been minimized.

Show comment
Hide comment
@mshibuya

mshibuya Sep 19, 2012

Collaborator

If you have some reason to precompile assets in dev env(though I don't think that's the right way), you can set

config.assets.debug = false

in your app's config/environments/development.rb to prevent duplication.

Collaborator

mshibuya commented Sep 19, 2012

If you have some reason to precompile assets in dev env(though I don't think that's the right way), you can set

config.assets.debug = false

in your app's config/environments/development.rb to prevent duplication.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment