rails_admin:install not function. #1368

Closed
higorfreire opened this Issue Oct 23, 2012 · 1 comment

Projects

None yet

2 participants

@higorfreire

Inserted this in terminal
sudo rails g rails_admin:install

That's the problem...-----------//------------
/Users/higorfreire/.rvm/rubies/ruby-1.9.3-p286/lib/ruby/site_ruby/1.9.1/rubygems/dependency.rb:247:in to_specs': Could not find rake (>= 0.8.7) amongst [actionmailer-3.2.8, actionpack-3.2.8, active_utils-1.0.5, activemerchant-1.28.0, activemodel-3.2.8, activerecord-3.2.8, activeresource-3.2.8, activesupport-3.2.8, arel-3.0.2, bcrypt-ruby-3.0.1, bootstrap-sass-2.1.0.1, builder-3.0.4, coffee-rails-3.2.2, coffee-script-2.2.0, coffee-script-source-1.3.3, countries-0.8.3, currencies-0.4.0, devise-2.1.2, erubis-2.7.0, execjs-1.4.0, font-awesome-sass-rails-2.0.0.0, haml-3.1.7, hike-1.2.1, i18n-0.6.1, journey-1.0.4, jquery-rails-2.1.3, jquery-ui-rails-2.0.2, json-1.7.5, kaminari-0.14.1, mail-2.4.4, mime-types-1.19, money-5.0.0, multi_json-1.3.6, mysql2-0.3.11, nested_form-0.2.3, nokogiri-1.5.5, orm_adapter-0.4.0, piggybak-0.6.7, piggybak-0.6.4, polyglot-0.3.3, rack-1.4.1, rack-cache-1.2, rack-pjax-0.6.0, rack-ssl-1.3.2, rack-test-0.6.2, rails-3.2.8, rails_admin-0.1.2, railties-3.2.8, rdoc-3.12, remotipart-1.0.2, sass-3.2.1, sass-rails-3.2.5, sprockets-2.1.3, sqlite3-1.3.6, thor-0.16.0, tilt-1.3.3, treetop-1.4.11, tzinfo-0.3.33, uglifier-1.3.0, warden-1.2.1] (Gem::LoadError) from /Users/higorfreire/.rvm/rubies/ruby-1.9.3-p286/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:777:inblock in activate_dependencies'
from /Users/higorfreire/.rvm/rubies/ruby-1.9.3-p286/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:766:in each' from /Users/higorfreire/.rvm/rubies/ruby-1.9.3-p286/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:766:inactivate_dependencies'
from /Users/higorfreire/.rvm/rubies/ruby-1.9.3-p286/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:750:in activate' from /Users/higorfreire/.rvm/rubies/ruby-1.9.3-p286/lib/ruby/site_ruby/1.9.1/rubygems.rb:1232:ingem'
from /Users/higorfreire/.rvm/gems/ruby-1.9.3-p286/bin/rails:18:in <main>' from /Users/higorfreire/.rvm/gems/ruby-1.9.3-p286/bin/ruby_noexec_wrapper:14:ineval'
from /Users/higorfreire/.rvm/gems/ruby-1.9.3-p286/bin/ruby_noexec_wrapper:14:in `

'

That's my GEMFILE -----------//------------

source 'https://rubygems.org'

gem 'rails', '3.2.8'
gem 'sqlite3'
gem "piggybak"
gem 'rails_admin'
gem 'devise'
gem 'jquery-rails'

group :assets do
gem 'sass-rails', '> 3.2.3'
gem 'coffee-rails', '
> 3.2.1'
gem 'uglifier', '>= 1.0.3'
end

Got no problem in the "bundle", just in "rails g rails_admin:install" command

@mshibuya
Collaborator

Please don't do sudo(that shouldn't be necessary).

If problem still exists, you can try

bundle exec rails g rails_admin:install

to make sure to load gems as described in Gemfile.

@mshibuya mshibuya closed this Oct 25, 2012
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment