Skip to content
This repository

Error run rails_admin ruby 1.9.3-p327 #1403

Closed
kraudio opened this Issue · 2 comments

2 participants

kraudio Erik Michaels-Ober
kraudio

With ruby 1.8.6 everything was fine

#$ rvm list

rvm rubies

ruby-1.8.7-p370 [ i686 ]
ruby-1.9.3-p194 [ x86_64 ]
=* ruby-1.9.3-p327 [ x86_64 ]

=> - current
=* - current && default

  • - default

#$ bundle install

Fetching gem metadata from https://rubygems.org/......
Fetching gem metadata from https://rubygems.org/..
Installing rake (0.9.2.2)
Installing i18n (0.6.1)
Installing multi_json (1.3.6)
Installing activesupport (3.2.8)
Installing builder (3.0.4)
Installing activemodel (3.2.8)
Installing erubis (2.7.0)
Installing journey (1.0.4)
Installing rack (1.4.1)
Installing rack-cache (1.2)
Installing rack-test (0.6.2)
Installing hike (1.2.1)
Installing tilt (1.3.3)
Installing sprockets (2.1.3)
Installing actionpack (3.2.8)
Installing mime-types (1.19)
Installing polyglot (0.3.3)
Installing treetop (1.4.12)
Installing mail (2.4.4)
Installing actionmailer (3.2.8)
Installing arel (3.0.2)
Installing tzinfo (0.3.34)
Installing activerecord (3.2.8)
Installing activeresource (3.2.8)
Installing bcrypt-ruby (3.0.1) with native extensions
Installing bootstrap-sass (2.1.0.1)
Installing cancan (1.6.8)
Installing highline (1.6.15)
Installing net-ssh (2.6.1)
Installing net-scp (1.0.4)
Installing net-sftp (2.0.5)
Installing net-ssh-gateway (1.1.0)
Installing capistrano (2.13.5)
Installing cocaine (0.4.2)
Installing coffee-script-source (1.4.0)
Installing execjs (1.4.0)
Installing coffee-script (2.2.0)
Installing rack-ssl (1.3.2)
Installing json (1.7.5) with native extensions
Installing rdoc (3.12)
Installing thor (0.16.0)
Installing railties (3.2.8)
Installing coffee-rails (3.2.2)
Installing orm_adapter (0.4.0)
Installing warden (1.2.1)
Installing devise (2.1.2)
Installing fastercsv (1.5.5)
Installing sass (3.2.1)
Installing sass-rails (3.2.5)
Installing font-awesome-sass-rails (2.0.0.0)
Installing haml (3.1.7)
Installing jquery-rails (2.1.3)
Installing jquery-ui-rails (2.0.2)
Installing kaminari (0.14.1)
Installing libv8 (3.3.10.4)
Installing nested_form (0.2.3)
Installing nokogiri (1.5.5) with native extensions
Installing paperclip (2.8.0)
Installing pg (0.13.2) with native extensions
Installing rack-pjax (0.6.0)
Using bundler (1.2.2)
Installing rails (3.2.8)
Installing remotipart (1.0.2)
Installing rails_admin (0.1.2)
Installing therubyracer (0.10.2) with native extensions
Installing uglifier (1.3.0)
Your bundle is complete! Use bundle show [gemname] to see where a bundled gem is installed.
Post-install message from rdoc:
Depending on your version of ruby, you may need to install ruby rdoc/ri data:

<= 1.8.6 : unsupported
= 1.8.7 : gem install rdoc-data; rdoc-data --install
= 1.9.1 : gem install rdoc-data; rdoc-data --install

= 1.9.2 : nothing to do! Yay!

#$ rails s -p 3004

=> Booting WEBrick
=> Rails 3.2.8 application starting in development on http://0.0.0.0:3004
=> Call with -d to detach
=> Ctrl-C to shutdown server
Exiting
/Users/claudio/.rvm/gems/ruby-1.9.3-p327/gems/activesupport-3.2.8/lib/active_support/dependencies.rb:245:in load': /Users/claudio/Sites/rails_ima/imahw/config/initializers/rails_admin.rb:9: invalid multibyte char (US-ASCII) (SyntaxError)
/Users/claudio/Sites/rails_ima/imahw/config/initializers/rails_admin.rb:9: invalid multibyte char (US-ASCII)
/Users/claudio/Sites/rails_ima/imahw/config/initializers/rails_admin.rb:9: syntax error, unexpected $end, expecting ']'
... Controle de Hardware e Licenças de Software']
... ^
from /Users/claudio/.rvm/gems/ruby-1.9.3-p327/gems/activesupport-3.2.8/lib/active_support/dependencies.rb:245:in
block in load'
from /Users/claudio/.rvm/gems/ruby-1.9.3-p327/gems/activesupport-3.2.8/lib/active_support/dependencies.rb:236:in load_dependency'
from /Users/claudio/.rvm/gems/ruby-1.9.3-p327/gems/activesupport-3.2.8/lib/active_support/dependencies.rb:245:in
load'
from /Users/claudio/.rvm/gems/ruby-1.9.3-p327/gems/railties-3.2.8/lib/rails/engine.rb:588:in block (2 levels) in <class:Engine>'
from /Users/claudio/.rvm/gems/ruby-1.9.3-p327/gems/railties-3.2.8/lib/rails/engine.rb:587:in
each'
from /Users/claudio/.rvm/gems/ruby-1.9.3-p327/gems/railties-3.2.8/lib/rails/engine.rb:587:in block in <class:Engine>'
from /Users/claudio/.rvm/gems/ruby-1.9.3-p327/gems/railties-3.2.8/lib/rails/initializable.rb:30:in
instance_exec'
from /Users/claudio/.rvm/gems/ruby-1.9.3-p327/gems/railties-3.2.8/lib/rails/initializable.rb:30:in run'
from /Users/claudio/.rvm/gems/ruby-1.9.3-p327/gems/railties-3.2.8/lib/rails/initializable.rb:55:in
block in run_initializers'
from /Users/claudio/.rvm/gems/ruby-1.9.3-p327/gems/railties-3.2.8/lib/rails/initializable.rb:54:in each'
from /Users/claudio/.rvm/gems/ruby-1.9.3-p327/gems/railties-3.2.8/lib/rails/initializable.rb:54:in
run_initializers'
from /Users/claudio/.rvm/gems/ruby-1.9.3-p327/gems/railties-3.2.8/lib/rails/application.rb:136:in initialize!'
from /Users/claudio/.rvm/gems/ruby-1.9.3-p327/gems/railties-3.2.8/lib/rails/railtie/configurable.rb:30:in
method_missing'
from /Users/claudio/Sites/rails_ima/imahw/config/environment.rb:5:in <top (required)>'
from /Users/claudio/.rvm/gems/ruby-1.9.3-p327/gems/activesupport-3.2.8/lib/active_support/dependencies.rb:251:in
require'
from /Users/claudio/.rvm/gems/ruby-1.9.3-p327/gems/activesupport-3.2.8/lib/active_support/dependencies.rb:251:in block in require'
from /Users/claudio/.rvm/gems/ruby-1.9.3-p327/gems/activesupport-3.2.8/lib/active_support/dependencies.rb:236:in
load_dependency'
from /Users/claudio/.rvm/gems/ruby-1.9.3-p327/gems/activesupport-3.2.8/lib/active_support/dependencies.rb:251:in require'
from /Users/claudio/Sites/rails_ima/imahw/config.ru:4:in
block in '
from /Users/claudio/.rvm/gems/ruby-1.9.3-p327/gems/rack-1.4.1/lib/rack/builder.rb:51:in instance_eval'
from /Users/claudio/.rvm/gems/ruby-1.9.3-p327/gems/rack-1.4.1/lib/rack/builder.rb:51:in
initialize'
from /Users/claudio/Sites/rails_ima/imahw/config.ru:1:in new'
from /Users/claudio/Sites/rails_ima/imahw/config.ru:1:in
'
from /Users/claudio/.rvm/gems/ruby-1.9.3-p327/gems/rack-1.4.1/lib/rack/builder.rb:40:in eval'
from /Users/claudio/.rvm/gems/ruby-1.9.3-p327/gems/rack-1.4.1/lib/rack/builder.rb:40:in
parse_file'
from /Users/claudio/.rvm/gems/ruby-1.9.3-p327/gems/rack-1.4.1/lib/rack/server.rb:200:in app'
from /Users/claudio/.rvm/gems/ruby-1.9.3-p327/gems/railties-3.2.8/lib/rails/commands/server.rb:46:in
app'
from /Users/claudio/.rvm/gems/ruby-1.9.3-p327/gems/rack-1.4.1/lib/rack/server.rb:301:in wrapped_app'
from /Users/claudio/.rvm/gems/ruby-1.9.3-p327/gems/rack-1.4.1/lib/rack/server.rb:252:in
start'
from /Users/claudio/.rvm/gems/ruby-1.9.3-p327/gems/railties-3.2.8/lib/rails/commands/server.rb:70:in start'
from /Users/claudio/.rvm/gems/ruby-1.9.3-p327/gems/railties-3.2.8/lib/rails/commands.rb:55:in
block in '
from /Users/claudio/.rvm/gems/ruby-1.9.3-p327/gems/railties-3.2.8/lib/rails/commands.rb:50:in tap'
from /Users/claudio/.rvm/gems/ruby-1.9.3-p327/gems/railties-3.2.8/lib/rails/commands.rb:50:in
'
from script/rails:6:in require'
from script/rails:6:in
'
#$

Erik Michaels-Ober
Owner

What does your config/initializers/rails_admin.rb look like? I'm guessing it has a non-ASCII character in it. Try adding the following line at the very top:

# encoding: utf-8
kraudio

Thanks

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.