Model display name fixes #319

Closed
wants to merge 6 commits into
from
Commits on Mar 10, 2011
  1. @papercheck

    Fix for asset loading issue:

    papercheck committed Mar 10, 2011
    When assets have been copied with rake admin:copy_assets, then rails_admin should NOT insert
    another ActionDispatch::Static middleware, because it eclipses Rails's native middleware and assets
    are loaded from rails_admin's public folder instead of the application's public folder.
    Fixed by checking if any of the rails_admin subdirectories exist in any of the static asset classes
    (images, javascripts, stylesheets).
    Also, if the middleware is inserted, it should be done AFTER, not IN FRONT of Rails's own static asset
    middleware, to permit precedence to the application's public folder over the gem's.
Commits on Mar 11, 2011
  1. @wolframarnold

    Merge in sferik/master which had the same fix for static asset loadin…

    wolframarnold committed Mar 11, 2011
    …g, but didn't check for the files to be present,
    
    which is cool.
Commits on Mar 14, 2011
  1. @wolframarnold
  2. @wolframarnold

    Fix display bug on dashboard page:

    wolframarnold committed Mar 14, 2011
    Model name in table is now using label override if present.
  3. @wolframarnold

    Fix display bug on list page:

    wolframarnold committed Mar 14, 2011
    @page_name should use overridden model name.
    Same for breadcrumbs.
    Spec coverage added.
  4. @wolframarnold

    Fixed several other references to model name for delete and history,

    wolframarnold committed Mar 14, 2011
    where @model_config.list.label was called, but @model_config.navigation.label should
    have been called.