Permalink
Browse files

Update faraday_middleware dependency to version 0.8

  • Loading branch information...
1 parent b34a195 commit 8a0c81964e7e3d3b21a0119e0ac6523f8223414a @sferik committed Feb 18, 2012
Showing with 4 additions and 4 deletions.
  1. +3 −3 lib/tradehill/connection.rb
  2. +1 −1 tradehill.gemspec
@@ -1,9 +1,9 @@
require 'faraday'
-require 'faraday_middleware'
require 'faraday/request/url_encoded'
require 'faraday/response/raise_tradehill_error'
require 'faraday/response/raise_error'
-require 'faraday/response/parse_json'
+require 'faraday_middleware'
+require 'faraday_middleware/response/parse_json'
require 'tradehill/version'
module TradeHill
@@ -23,7 +23,7 @@ def connection(options={})
connection.use Faraday::Request::UrlEncoded
connection.use Faraday::Response::RaiseTradeHillError
connection.use Faraday::Response::RaiseError
- connection.use Faraday::Response::ParseJson
+ connection.use FaradayMiddleware::ParseJson
connection.adapter(Faraday.default_adapter)
end
end
View
@@ -3,7 +3,7 @@ require File.expand_path('../lib/tradehill/version', __FILE__)
Gem::Specification.new do |gem|
gem.add_dependency 'faraday', '~> 0.7'
- gem.add_dependency 'faraday_middleware', '~> 0.7'
+ gem.add_dependency 'faraday_middleware', '~> 0.8'
gem.add_dependency 'multi_json', '~> 1.0'
gem.add_development_dependency 'json'
gem.add_development_dependency 'rake'

0 comments on commit 8a0c819

Please sign in to comment.