Permalink
Browse files

Switch from YAJL to MultiJson (@MichaelRykov)

  • Loading branch information...
1 parent ca12ccb commit 60a7cb179e77319e03c595850119b63fb413a53d @sferik committed Sep 23, 2010
Showing with 6 additions and 6 deletions.
  1. +3 −3 Gemfile.lock
  2. +2 −2 lib/twitter.rb
  3. +1 −1 twitter.gemspec
View
@@ -4,8 +4,8 @@ PATH
twitter (0.9.10)
hashie (~> 0.4.0)
httparty (~> 0.6.1)
+ multi_json (~> 0.0.4)
oauth (~> 0.4.3)
- yajl-ruby (~> 0.7.7)
GEM
remote: http://rubygems.org/
@@ -18,10 +18,10 @@ GEM
jnunemaker-matchy (0.4.0)
mocha (0.9.8)
rake
+ multi_json (0.0.4)
oauth (0.4.3)
rake (0.8.7)
shoulda (2.11.3)
- yajl-ruby (0.7.7)
PLATFORMS
ruby
@@ -32,7 +32,7 @@ DEPENDENCIES
httparty (~> 0.6.1)
jnunemaker-matchy (~> 0.4.0)
mocha (~> 0.9.8)
+ multi_json (~> 0.0.4)
oauth (~> 0.4.3)
shoulda (~> 2.11.3)
twitter!
- yajl-ruby (~> 0.7.7)
View
@@ -2,7 +2,7 @@
require "oauth"
require "hashie"
require "httparty"
-require "yajl"
+require "multi_json"
module Twitter
include HTTParty
@@ -109,7 +109,7 @@ def self.raise_errors(response)
end
def self.parse(response)
- Yajl::Parser.parse(response.body)
+ MultiJson.decode(response.body)
end
def self.mash(obj)
View
@@ -9,7 +9,7 @@ Gem::Specification.new do |s|
s.add_runtime_dependency("hashie", ["~> 0.4.0"])
s.add_runtime_dependency("httparty", ["~> 0.6.1"])
s.add_runtime_dependency("oauth", ["~> 0.4.3"])
- s.add_runtime_dependency("yajl-ruby", ["~> 0.7.7"])
+ s.add_runtime_dependency("multi_json", ["~> 0.0.4"])
s.authors = ["John Nunemaker", "Wynn Netherland", "Erik Michaels-Ober"]
s.description = %q{Ruby wrapper for the Twitter API}
s.email = ["nunemaker@gmail.com"]

0 comments on commit 60a7cb1

Please sign in to comment.