Browse files

Removed sqlite3-ruby as a dependency during install as it is only use…

…d with CLI. Just install it if you use the CLI.
  • Loading branch information...
1 parent 2354d4f commit 9277e832daf9539e70f446b8b4f7093d8eb98484 @jnunemaker jnunemaker committed Aug 4, 2008
Showing with 10 additions and 10 deletions.
  1. +2 −0 README.txt
  2. +1 −2 config/hoe.rb
  3. +1 −1 lib/twitter/cli.rb
  4. +1 −1 lib/twitter/version.rb
  5. +2 −5 twitter.gemspec
  6. +3 −1 website/index.html
View
2 README.txt
@@ -45,6 +45,8 @@ sudo gem install twitter will work just fine. For command line use, you'll need
== Command Line Use
+
+Note: If you want to use twitter from the command line be sure that sqlite3 and the sqlite3-ruby gem are installed. I removed the sqlite3-ruby gem as a dependency because you shouldn't need that to just use the API wrapper. Eventually I'll move the CLI interface into another gem.
$ twitter
View
3 config/hoe.rb
@@ -63,8 +63,7 @@ def extra_deps
#p.extra_deps = [] # An array of rubygem dependencies [name, version], e.g. [ ['active_support', '>= 1.3.1'] ]
p.extra_deps = [['hpricot', '>= 0.6'], ['activesupport', '>= 2.1'],
['main', '>= 2.8.2'], ['highline', '>= 1.4.0'],
- ['activerecord', '>= 2.1'], ['sqlite3-ruby', '>= 1.2.2'],
- ['httparty', '>= 0.1.0']]
+ ['activerecord', '>= 2.1'], ['httparty', '>= 0.1.0']]
#p.spec_extras = {} # A hash of extra values to set in the gemspec.
end
View
2 lib/twitter/cli.rb
@@ -2,7 +2,7 @@
gem 'main', '>= 2.8.2'
gem 'highline', '>= 1.4.0'
gem 'activerecord', '>= 2.1'
-gem 'sqlite3-ruby', '>= 1.2.2'
+gem 'sqlite3-ruby', '>= 1.2.1'
require 'main'
require 'highline/import'
require 'activerecord'
View
2 lib/twitter/version.rb
@@ -2,7 +2,7 @@ module Twitter #:nodoc:
module VERSION #:nodoc:
MAJOR = 0
MINOR = 3
- TINY = 4
+ TINY = 5
STRING = [MAJOR, MINOR, TINY].join('.')
end
View
7 twitter.gemspec
@@ -1,10 +1,10 @@
Gem::Specification.new do |s|
s.name = %q{twitter}
- s.version = "0.3.4"
+ s.version = "0.3.5"
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
s.authors = ["John Nunemaker"]
- s.date = %q{2008-08-03}
+ s.date = %q{2008-08-04}
s.default_executable = %q{twitter}
s.description = %q{a command line interface for twitter, also a library which wraps the twitter api}
s.email = %q{nunemaker@gmail.com}
@@ -29,15 +29,13 @@ Gem::Specification.new do |s|
s.add_runtime_dependency(%q<main>, [">= 2.8.2"])
s.add_runtime_dependency(%q<highline>, [">= 1.4.0"])
s.add_runtime_dependency(%q<activerecord>, [">= 2.1"])
- s.add_runtime_dependency(%q<sqlite3-ruby>, [">= 1.2.2"])
s.add_runtime_dependency(%q<httparty>, [">= 0.1.0"])
else
s.add_dependency(%q<hpricot>, [">= 0.6"])
s.add_dependency(%q<activesupport>, [">= 2.1"])
s.add_dependency(%q<main>, [">= 2.8.2"])
s.add_dependency(%q<highline>, [">= 1.4.0"])
s.add_dependency(%q<activerecord>, [">= 2.1"])
- s.add_dependency(%q<sqlite3-ruby>, [">= 1.2.2"])
s.add_dependency(%q<httparty>, [">= 0.1.0"])
end
else
@@ -46,7 +44,6 @@ Gem::Specification.new do |s|
s.add_dependency(%q<main>, [">= 2.8.2"])
s.add_dependency(%q<highline>, [">= 1.4.0"])
s.add_dependency(%q<activerecord>, [">= 2.1"])
- s.add_dependency(%q<sqlite3-ruby>, [">= 1.2.2"])
s.add_dependency(%q<httparty>, [">= 0.1.0"])
end
end
View
4 website/index.html
@@ -84,9 +84,11 @@
</code></pre>
<h2>Command Line</h2>
-
+
<p><img src="images/terminal_output.png" alt="Terminal Output" style="width:560px;" /></p>
+ <p><strong>Note: If you want to use twitter from the command line be sure that sqlite3 and the sqlite3-ruby gem are installed.</strong> I removed the sqlite3-ruby gem as a dependency because you shouldn't need that to just use the API wrapper. Eventually I'll move the CLI interface into another gem.</p>
+
<p>The first thing you'll want to do is install the database so your account(s) can be stored.</p>
<pre><code>$ twitter install</code></pre>

0 comments on commit 9277e83

Please sign in to comment.