Skip to content
Browse files

Fixed that source param wasn't getting through. Must have messed that…

… up in previous release as it was working. [#11 state:resolved]
  • Loading branch information...
1 parent 8a802c4 commit e3743cf22df3ad9406bf8c2e4425f30680606283 @jnunemaker jnunemaker committed Aug 26, 2008
Showing with 7 additions and 4 deletions.
  1. +3 −0 History.txt
  2. +1 −1 lib/twitter/base.rb
  3. +1 −1 lib/twitter/version.rb
  4. +2 −2 twitter.gemspec
View
3 History.txt
@@ -1,3 +1,6 @@
+0.3.7 - August 26, 2008
+ * Fixed source param not getting through
+
0.3.6 - August 11, 2008
* Fixed a few more methods that required post.
* Refactored the remaining methods that were not using #request to use it.
View
2 lib/twitter/base.rb
@@ -158,7 +158,7 @@ def unblock(id)
# Posts a new update to twitter for auth user.
def post(status, options={})
form_data = {'status' => status}
- form_data.merge({'source' => options[:source]}) if options[:source]
+ form_data.merge!({'source' => options[:source]}) if options[:source]
Status.new_from_xml(request('statuses/update.xml', :auth => true, :method => :post, :form_data => form_data))
end
alias :update :post
View
2 lib/twitter/version.rb
@@ -2,7 +2,7 @@ module Twitter #:nodoc:
module VERSION #:nodoc:
MAJOR = 0
MINOR = 3
- TINY = 6
+ TINY = 7
STRING = [MAJOR, MINOR, TINY].join('.')
end
View
4 twitter.gemspec
@@ -1,10 +1,10 @@
Gem::Specification.new do |s|
s.name = %q{twitter}
- s.version = "0.3.6"
+ s.version = "0.3.7"
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
s.authors = ["John Nunemaker"]
- s.date = %q{2008-08-11}
+ s.date = %q{2008-08-26}
s.default_executable = %q{twitter}
s.description = %q{a command line interface for twitter, also a library which wraps the twitter api}
s.email = %q{nunemaker@gmail.com}

0 comments on commit e3743cf

Please sign in to comment.
Something went wrong with that request. Please try again.