Permalink
Browse files

Fix conditional inclusion of jruby-openssl in Ruby 1.9

Closes #118
  • Loading branch information...
1 parent 4723f45 commit e8e9b1d7232bf69ac5e217e2e18dc9c8e75f2fc4 @sferik committed Nov 16, 2010
Showing with 1 addition and 1 deletion.
  1. +1 −1 twitter.gemspec
View
@@ -15,7 +15,7 @@ Gem::Specification.new do |s|
s.add_runtime_dependency("hashie", "~> 0.4.0")
s.add_runtime_dependency("faraday", "~> 0.5.3")
s.add_runtime_dependency("faraday_middleware", "~> 0.3.0")
- s.add_runtime_dependency("jruby-openssl", "~> 0.7.2") if PLATFORM == 'java'
+ s.add_runtime_dependency("jruby-openssl", "~> 0.7.2") if defined?(RUBY_ENGINE) && RUBY_ENGINE == 'jruby'
s.add_runtime_dependency("multi_json", "~> 0.0.5")
s.add_runtime_dependency("multi_xml", "~> 0.2.0")
s.add_runtime_dependency("simple_oauth", "~> 0.1.2")

0 comments on commit e8e9b1d

Please sign in to comment.