Swifty, modern UIAlertController wrapper.
Clone or download
Latest commit 429ffd0 Nov 14, 2018

README.md

Alertift

logo

Alertift.alert(title: "Alertift", message: "Alertift is swifty, modern, and awesome UIAlertController wrapper.")
    .action(.default("❤️"))
    .action(.default(""))
    .show(on: self)

GitHub release Language Carthage Compatible CocoaPods CocoaPodsDL

Feature

  • Method chain.
  • Can add multiple actions at once.
  • UITextField support.
  • Image support. (above v3.1)
  • iPad support(Action Sheet, popover).
  • Can change title/message/button text/ background color without using private APIs.
  • Can change title/message's alignment without using private APIs.

How to use

👉👉👉 How to use

Requirements

  • iOS 9.0+
  • Xcode 8.1+
  • Swift 3.0+

Installation

Carthage

  • Add the following to your Cartfile:
# Swift4.2 or later
github "sgr-ksmt/Alertift" ~> 4.0

# Swift4 or 4.1
github "sgr-ksmt/Alertift" ~> 3.2

# Less than Swift4
github "sgr-ksmt/Alertift" ~> 2.0
  • Run carthage update
  • Add the framework as described.
    Details: Carthage Readme

CocoaPods

Alertift is available through CocoaPods. To install it, simply add the following line to your Podfile:

# Swift4.2 or later
pod 'Alertift', '~> 4.0'

# Swift4 or 4.1
pod 'Alertift', '~> 3.0'

# Less than Swift4
pod 'Alertift', '~> 2.0'

and run pod install

Manually Install

Download all *.swift files and put your project.

Change log

Change log is here.

Communication

  • If you found a bug, open an issue.
  • If you have a feature request, open an issue.
  • If you want to contribute, submit a pull request.💪

License

Alertift is under MIT license. See the LICENSE file for more info.