@librehat librehat released this Jan 4, 2018 · 7 commits to master since this release

Assets 3

What's New

  1. Minimum requirement of libQtShadowsocks is bumped to 2.0.0, which brings Shadowsocks AEAD support (Botan-2 is required for this feature) and Shadowsocks SIP002 URI scheme support
  2. Log viewer is now removed due to the logging changes in libQtShadowsocks
  3. Application indicator is now removed (#522)
  4. CMake build system (#521)
  5. Other bugs fixed (#562 #577)
  6. You need a compiler that supports C++14 to build this project
  7. debian directory is removed from this repository and I will no longer maintain the Ubuntu PPA. All packaging is now up to communities except for Fedora Copr.

For any x86_64 Linux distributions, download AppImage file, run chmod a+x Shadowsocks-Qt5-3.0.0-x86_64.AppImage then you can enjoy shadowsocks-qt5 on your system by simply double clicking (or run it fro m terminal).

The AppImage is built on Debian Wheezy with custom built Qt 5.10, Botan 2.3.0, GCC 5.5

SHA1SUM

a9c885ff84c4f1dda2b1ffbb4a5ed636cbf9631b  Shadowsocks-Qt5-3.0.0-x86_64.AppImage