Skip to content

Loading…

LoadError win32/open3 #1

Closed
shreyasbharath opened this Issue · 2 comments

2 participants

@shreyasbharath

I get the below error when I try to require popen4 on Windows with Ruby v1.9.3-p362.

Why isn't win32-open3 a dependency of popen4?

C:/Ruby193/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in `require': cannot load such file -- win32/open3 (LoadError)
@shairontoledo

If we add this gem dependency others unix-based platforms will install win32 as default in which it is not desired.
We could however create a new gemspec with another name to do such thing.

@shreyasbharath

That sounds like a good idea, one would expect all dependent gems to be installed.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.