Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
An IP Messenger implementation in Python.
Python
branch: master
Failed to load latest commit information.
ipmsg Use with statements for easier reading.
.gitignore Add .gitignore
INSTALL init
MANIFEST.in distribute
README.md Update README.md
requirements.txt Killed the good guy by mistake.
setup.py Add commandline interface

README.md

ipmsg

An IP Messenger(http://www.ipmsg.org) library for Linux, written in python.

For the GUI frontend, checkout https://github.com/shaung/ipmsg-pygtk

Requirements

  • Python 2.6 or above. Python 3 support is not included for now.

Dependencies

  • PyCrypto
  • rsa

Installation

From pypi:

pip install ipmsg

Or install from source:

python setup.py install

Command-line usage

ipmsg [--port=<port>] [--user=<username>] [--group=<groupname>] [-s|--seal] [--help]
      <message-to-send> ip[:port]

License

Released under the BSD license.

Troubleshooting

  • Not compatible with IP Messager 3.x yet.
Something went wrong with that request. Please try again.