Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

DeprecationWarning regarding strict argument in connection.py #342

Closed
Kruptein opened this Issue Feb 21, 2014 · 3 comments

Comments

Projects
None yet
2 participants

When using requests which includes urllib3 I get this deprecationwarning that traces back to connection.py.

It doesn't break code but just clutters logs.

'C:\Python33\lib\sitepackages\requests\packages\urllib3\connection.py:99: DeprecationWarning: the ´strict´ argument isn´t supported anymore; http.client now always assumes HTTP/1.x compliant servers.
HTTPConnection.init(self, host, port, strict, timeout, source_address)'

Owner

shazow commented Feb 21, 2014

Mmmm looks like a regression of #238/#239. :(

We need to add a test/configuration to break on DeprecationWarning which travisci would ideally catch under py3.

Owner

shazow commented Feb 21, 2014

@Kruptein Could you give me a quick sanity check before I merge? Here's my PR: #343

Sorry, my github notifications were set up wrong :)

Now, it seems that that solved the error, I don't get any warnings anymore and my code still works as expected.
Thanks!

@shazow shazow closed this in #343 Feb 22, 2014

@hynekcer hynekcer referenced this issue in requests/requests Mar 15, 2014

Closed

HTTPConnection strict deprecated since 3.2 #1382

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment