Save time and headaches, and create a more easily maintainable set of pages, with ActiveScaffold. ActiveScaffold handles all your CRUD (create, read, update, delete) user interface needs, leaving you more time to focus on more challenging (and interesting!) problems.
Ruby JavaScript
Pull request Compare This branch is 1651 commits ahead, 3968 commits behind activescaffold:master.
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Failed to load latest commit information.


ActiveScaffold Gem/Plugin by Scott Rutherford (, Richard White (, Lance Ivy (, Ed Moss, Tim Harper and Sergio Cambra (

Uses DhtmlHistory by Brad Neuberg (

Uses Querystring by Adam Vandenberg

Uses Paginator by Bruce Williams

Supports RecordSelect by Lance Ivy

== Version Information

If you want to use the gem, add to your Gemfile:
  gem "active_scaffold"

In case you would like to use most recent commit:
  gem 'active_scaffold', :git => 'git://'

3.1.* and 3.2.* versions works with rails 3.1 and 3.2, 3.0.* versions with rails 3.0.
To use previous rails versions you will have to install the right branch as a plugin.

Active Scaffold master currently supports rails 3.1 and rails 3.2, you can use following branches for previous rails versions:
Rails 3.0.*: Active Scaffold rails-3.0
Rails 2.3.*: Active Scaffold rails-2.3 and v2.4
Rails 2.2.*: Active Scaffold rails-2.2
Rails 2.1.*: Active Scaffold rails-2.1
Rails < 2.1: Active Scaffold 1-1-stable (no guarantees)

Since Rails 2.3, render_component plugin is needed for nested and embedded scaffolds. It works with rails-2.3 branch from ewildgoose repository:
script/plugin install git:// -r rails-2.3

Since Rails 3.0 render_component is not used for nesting, but is optional for embedded scaffolds.
For Rails 3.0, is also needed, not in rails 3.1 or higher.

If you want to install as plugins under vendor/plugins, install these versions:
  rails plugin install git://
  rails plugin install git://
  rails plugin install git:// -r 'rails-3.0'

== Pick your own javascript framework

The Rails 3.0 version uses unobtrusive Javascript, so you are free to pick your javascript framework.
Out of the box Prototype or JQuery are supported for rails 3.1 and later. For rails 3.0 pick a JS file:

Prototype 1.7 (default js framework)
rails.js in git://

JQuery 1.4.1, 1.4.2

JQuery > 1.4.2

To configure the javascript framework when installed under vendor/plugins/
uncomment last line in config/initializers/active_scaffold.rb in order to use jquery instead of prototype.
That file is created when you install ActiveScaffold as a plugin.

To configure the javascript framework when installed as a gem:
Add a config/initializers/active_scaffold.rb containing:
ActiveScaffold.js_framework = :jquery # :prototype is the default

Released under the MIT license (included)