Skip to content
Permalink
Browse files

Adjust Travis config and add matrices to build with gcc-{5,6}

* Force Travis to run "autoreconf -fi" to avoid errors during
  build script configure due to the different autotools version.
* Add matrices to build with gcc-{5,6}
* Also trigger Travis to build the branch that start with "devel_"
  • Loading branch information...
neutronth committed Jun 16, 2016
1 parent d4b1840 commit c5084f4df2a6f56f90644ab5bbe368778e90d7b0
Showing with 31 additions and 1 deletion.
  1. +31 −1 .travis.yml
@@ -3,8 +3,38 @@ language: cpp
branches:
only:
- master
- /^devel_.*$/

before_script: ./configure
before_install:
- if [ -n "$GCC_VERSION" ]; then export CXX="g++-${GCC_VERSION}" CC="gcc-${GCC_VERSION}"; fi
- which $CXX
- which $CC

before_script:
- autoreconf -fi
- ./configure

script:
- make

matrix:
include:
- compiler: gcc
- compiler: gcc
addons:
apt:
sources:
- ubuntu-toolchain-r-test
packages:
- gcc-5
- g++-5
env: GCC_VERSION=5
- compiler: gcc
addons:
apt:
sources:
- ubuntu-toolchain-r-test
packages:
- gcc-6
- g++-6
env: GCC_VERSION=6

0 comments on commit c5084f4

Please sign in to comment.
You can’t perform that action at this time.