Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Drop node v4 support #873

Closed
4 tasks
nfischer opened this issue Jul 12, 2018 · 2 comments
Closed
4 tasks

Drop node v4 support #873

nfischer opened this issue Jul 12, 2018 · 2 comments

Comments

@nfischer
Copy link
Member

@nfischer nfischer commented Jul 12, 2018

According to the Node LTS schedule, v4 is no longer maintained, and v6 is in maintenance mode until April 2019.

We shouldn't bother supported unsupported node versions. shelljs@v0.9.0 (our next release) should be the last minor release to support v4.

  • bump package.engines
  • change README ("ShellJS is proudly tested on every node release since...")
  • drop v4 & v5 from travis/appveyor
  • do all the same for shx
@nfischer nfischer added this to the v1.0.0 milestone Jul 12, 2018
@nfischer nfischer removed this from the v1.0.0 milestone Oct 27, 2018
@nfischer nfischer added this to the v0.9.0 milestone Oct 27, 2018
@nfischer nfischer self-assigned this Nov 29, 2018
@nfischer
Copy link
Member Author

@nfischer nfischer commented Nov 29, 2018

I'll probably write a script to automate most of these steps (and to enforce all of these spots stay in-sync).

@nfischer
Copy link
Member Author

@nfischer nfischer commented Nov 29, 2018

Unfortunately, I think we need to bump priority. It seems appveyor node@4 is too flaky (#893 (comment)).

nfischer added a commit that referenced this issue Nov 30, 2018
No change to node support, this just adds a script.

This adds a script to check that we correctly configure all supported
node versions, since we need to update quite a few spots (README.md,
package.json, travis, appveyor).

Issue #873
Test: manual
nfischer added a commit that referenced this issue Dec 2, 2018
No change to node support, this just adds a script.

This adds a script to check that we correctly configure all supported
node versions, since we need to update quite a few spots (README.md,
package.json, travis, appveyor).

Issue #873
Test: manual
nfischer added a commit that referenced this issue Dec 2, 2018
This drops support for node v4 and v5. Neither is currently supported by
the Node.js team, nor by the `npm` CLI team, so it's hard to justify we
continue to support it.

The new minimum supported version is v6.

Fixes #873
nfischer added a commit to shelljs/shx that referenced this issue Dec 2, 2018
No change to node support, this just adds a script.

This adds a script to check that we correctly configure all supported
node versions, since we need to update quite a few spots (README.md,
package.json, travis, appveyor).

Issue shelljs/shelljs#873
Test: manual
@nfischer nfischer closed this in #917 Dec 2, 2018
nfischer added a commit that referenced this issue Dec 2, 2018
This drops support for node v4 and v5. Neither is currently supported by
the Node.js team, nor by the `npm` CLI team, so it's hard to justify we
continue to support it.

The new minimum supported version is v6.

Fixes #873
nfischer added a commit to shelljs/shx that referenced this issue Dec 2, 2018
* chore: script to bump supported node versions

No change to node support, this just adds a script.

This adds a script to check that we correctly configure all supported
node versions, since we need to update quite a few spots (README.md,
package.json, travis, appveyor).

Issue shelljs/shelljs#873
Test: manual

* rename package variable

* configure lint
nfischer added a commit to shelljs/shx that referenced this issue Dec 2, 2018
This drops support for node v4 and v5. Neither is currently supported by
the Node.js team, nor by the `npm` CLI team, so it's hard to justify we
continue to support it.

The new minimum supported version is v6.

This also fixes a bug in the check-node-support script.

Issue shelljs/shelljs#873
nfischer added a commit to shelljs/shx that referenced this issue Dec 2, 2018
This drops support for node v4 and v5. Neither is currently supported by
the Node.js team, nor by the `npm` CLI team, so it's hard to justify we
continue to support it.

The new minimum supported version is v6.

This also fixes a bug in the check-node-support script.

Issue shelljs/shelljs#873
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
1 participant