New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Can't use 'defined(@array)' error #6

Open
frymor opened this Issue Jul 17, 2017 · 1 comment

Comments

Projects
None yet
2 participants
@frymor

frymor commented Jul 17, 2017

I'm trying to use the diffReps.pl script and have install it using the cpanm method with all the dependencies. But when I am tryoing to run it I keep getting the error message

Can't use 'defined(@array)' (Maybe you should just omit the defined()?) at /usr/local/bin/diffReps.pl line 465.

I'm running it on Ubuntu 16.04 with perl version 5.22

any Ideas?
thanks
Assa

@plantformatics

This comment has been minimized.

plantformatics commented Sep 5, 2017

'defined' has been deprecated in the newer versions of perl. You can resolve this issue by editing the diffReps.pl on line 465. Simply remove "defined" from the code and it should run normally.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment