New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Installing from npm package fails #40

Closed
stevenroose opened this Issue Dec 3, 2018 · 1 comment

Comments

1 participant
@stevenroose

stevenroose commented Dec 3, 2018

I'm trying to install without having to fetch dependencies that are not exactly the version spark was tested/released with.

So I think the npm package install like described in the README is the way to go. Just to make sure, that install method either (1) contains all dependencies inside the package or (2) verifies the checksum of all dependencies before installing, right?

So trying to install this way, I get the following error:

$ npm install ./spark-wallet-0.1.3-npm.tgz
npm WARN engine spark-wallet@0.1.3: wanted: {"node":">=6.0.0"} (current: {"node":"0.10.29","npm":"1.4.21"})
The authenticity of host 'github.com (192.30.253.113)' can't be established.
RSA key fingerprint is 16:27:ac:a5:76:28:2d:36:63:1b:56:4d:eb:df:a6:48.
-/e you sure you want to continue connecting (yes/no)? -
npm ERR! git clone git@github.com:github:shesek/lightning-client-js Cloning into bare repository '/home/steven/.npm/_git-remotes/git-github-com-github-shesek-lightning-client-js-49dbdb4c'...
npm ERR! git clone git@github.com:github:shesek/lightning-client-js Warning: Permanently added 'github.com,192.30.253.113' (RSA) to the list of known hosts.
npm ERR! git clone git@github.com:github:shesek/lightning-client-js Permission denied (publickey).
npm ERR! git clone git@github.com:github:shesek/lightning-client-js fatal: Could not read from remote repository.
npm ERR! git clone git@github.com:github:shesek/lightning-client-js 
npm ERR! git clone git@github.com:github:shesek/lightning-client-js Please make sure you have the correct access rights
npm ERR! git clone git@github.com:github:shesek/lightning-client-js and the repository exists.
npm ERR! notarget No compatible version found: lightning-client@'github:shesek/lightning-client-js#ccb565d889803bce65a1a0e42d3948332a7fcdac'
npm ERR! notarget Valid install targets:
npm ERR! notarget ["0.5.2-beta.1","0.5.2-beta.2","0.5.2-beta.3","0.5.2-beta.4","0.5.2-beta.5","0.5.2-beta.6","0.5.2-beta.7","0.5.2-beta.8"]
npm ERR! notarget 
npm ERR! notarget This is most likely not a problem with npm itself.
npm ERR! notarget In most cases you or one of your dependencies are requesting
npm ERR! notarget a package version that doesn't exist.

npm ERR! System Linux 3.16.0-6-amd64
npm ERR! command "/usr/bin/nodejs" "/usr/bin/npm" "install" "./spark-wallet-0.1.3-npm.tgz"
npm ERR! cwd /home/steven/spark
npm ERR! node -v v0.10.29
npm ERR! npm -v 1.4.21
npm ERR! code ETARGET
npm ERR! 
npm ERR! Additional logging details can be found in:
npm ERR!     /home/steven/spark/npm-debug.log
npm ERR! not ok code 0
@stevenroose

This comment has been minimized.

stevenroose commented Dec 3, 2018

Ok it seems to have worked with an updated nodejs version. The default Debian one seems to be very old.

@stevenroose stevenroose closed this Dec 3, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment