Skip to content

Releases: shivammathur/setup-php

2.30.5

03 Jun 08:14
fc14643
Compare
Choose a tag to compare

Changelog

  • Added support for Ubuntu 24.04.

  • Added support for easy-coding-standard in tools (#838)

  • Added support for zephir_parser for PHP 8.3.

  • Fixed installing zts PHP versions on macOS (#847).

  • Fixed installing ev extension (#844).

  • Fixed support for ioncube extension (#840).

  • Updated Node.js dependencies.

For the complete list of changes, please refer to the Full Changelog

Follow for updates

setup-php reddit setup-php twitter setup-php status

2.30.4

23 Apr 22:29
c665c7a
Compare
Choose a tag to compare

Changelog

  • Fixed support for sqlsrv and pro_sqlsrv on Windows (#835).

  • Fixed a permissions issue for brew on macos-14 environments.

  • Marked PHP 5.3 to PHP 5.5 as not supported on ARM64 macOS environments like macos-14.

For the complete list of changes, please refer to the Full Changelog

Follow for updates

setup-php reddit setup-php twitter setup-php status

2.30.3

21 Apr 16:54
efffd0e
Compare
Choose a tag to compare

Changelog

  • Fixed reading extension directory for PHP 8.4 on macOS.

For the complete list of changes, please refer to the Full Changelog

Follow for updates

setup-php reddit setup-php twitter setup-php status

2.30.2

30 Mar 22:30
8872c78
Compare
Choose a tag to compare

Changelog

  • Added support for vld extension (shivammathur/homebrew-extensions#3827).

  • Added support to update brew along with the core tap on macOS to handle breaking changes in core tap formulae.

  • Updated Node.js dependencies.

For the complete list of changes, please refer to the Full Changelog

Follow for updates

setup-php reddit setup-php twitter setup-php status

2.30.1

25 Mar 08:57
73963f5
Compare
Choose a tag to compare

Changelog

  • Improved updating Homebrew core tap on macOS using a retry logic.

  • Fixed support for phalcon on Windows.

  • Fixed support for OCI extensions for PHP 8.4 on Linux and macOS.

  • Fixed support for sqlsrv and pdo_sqlsrv on PHP 8.0.

  • Fixed type error on Windows in Get-File function.

  • Minified the release file dist/index.js file generated by vercel/ncc.

  • Updated pre-installed PHP versions for GitHub runners in the README.

  • Updated Node.js dependencies.

For the complete list of changes, please refer to the Full Changelog

Follow for updates

setup-php reddit setup-php twitter setup-php status

2.30.0

01 Mar 10:33
Compare
Choose a tag to compare

Changelog

  • Added support to set custom composer timeout (#811)
- name: Setup PHP
  uses: shivammathur/setup-php@v2
  with:
    php-version: '8.3'
  env:
    COMPOSER_PROCESS_TIMEOUT: 300
  • Fixed syncing dependency formulae on macOS. (#823, #825, #824)

  • Updated Node.js dependencies.

For the complete list of changes, please refer to the Full Changelog

Follow for updates

setup-php reddit setup-php twitter setup-php status

2.29.0

15 Jan 09:42
6d7209f
Compare
Choose a tag to compare

Changelog

  • Added support for 'lowest' and 'highest' aliases to specify PHP versions. #794
    • The lowest alias installs the lowest actively supported version in the PHP project.
    • The 'highest' alias is equivalent to the 'latest' alias, so it installs the latest supported stable PHP version.
- name: Setup PHP
  uses: shivammathur/setup-php@v2
  with:
    php-version: lowest # or highest
  • Added support for thread-safe builds on macOS. This completes the support for thread-safe builds on all supported platforms.
- name: Setup ZTS PHP
  uses: shivammathur/setup-php@v2
  with:
    php-version: '8.3'
  env:
    phpts: zts
  • Updated documentation for support to read the PHP version from composer.lock and composer.json files.
    • If php-version and php-version-file inputs are not specified, then it can read the php version from platform-overrides.php value in composer.lock or config.platform.php value from composer.json. #800
- name: Checkout
  uses: actions/checkout@v4
- name: Setup PHP
  uses: shivammathur/setup-php@v2
  • Switched to the new PHPCSStandards/PHP_CodeSniffer repository for builds of phpcs and phpcbf tools. #809
- name: Setup PHP
  uses: shivammathur/setup-php@v2
  with:
    php-version: '8.3'
    tools: phpcs, phpcbf
  • Marked v1 version of the action as completely unsupported, it will receive no updates, please upgrade to v2, if not done already.

  • Fixed installing extensions on Windows for PHP 8.1 by reverting the version bump for minimum stability. #807

  • Fixed building extensions on PHP 8.4 that used backward compatibility headers from ext/standard to use ext/random/php_random.h header.

  • Improved support for phalcon to install the extension when specified without the version number. #796

- name: Setup PHP
  uses: shivammathur/setup-php@v2
  with:
    php-version: '8.3'
    extensions: phalcon
  • Updated codeql workflow to use v3 versions of codeql actions. #803

  • Updated docs workflow to use actions/download-artifact@v4 and actions/upload-artifact@v4. #804, #805

  • Updated Node.js dependencies.

Merged Pull Requests

For the complete list of changes, please refer to the Full Changelog

Thanks @dr5hn, @tighten, @ZeekInteractive, @acelaya, and @fulopattila122 for the sponsorship ❤️

Follow for updates

setup-php reddit setup-php twitter setup-php status

2.28.0

27 Nov 12:52
e6f7513
Compare
Choose a tag to compare

Changelog

  • Specifying 8.3 in php-version now installs a stable build of PHP 8.3.
- name: Setup PHP 8.3
  uses: shivammathur/setup-php@v2
  with:
    php-version: '8.3'
  • Specifying latest in php-version now installs PHP 8.3 as well.
- name: Setup Latest PHP
  uses: shivammathur/setup-php@v2
  with:
    php-version: 'latest'
  • Specifying nightly in php-version now installs PHP 8.4.
- name: Setup Nightly PHP
  uses: shivammathur/setup-php@v2
  with:
    php-version: 'nightly'
- name: Setup PHP with intl
  uses: shivammathur/setup-php@v2
  with:
    php-version: '8.3'
    extensions: intl-74.1
  • Added support to specify zts in phpts environment variable instead of ts to set up thread-safe PHP on Linux and Windows.
- name: Setup PHP 8.3 (ZTS)
  uses: shivammathur/setup-php@v2
  with:
    php-version: '8.3'
  env:
    phpts: zts
  • Fixed support for debug builds. (#784)
- name: Setup PHP 8.3
  uses: shivammathur/setup-php@v2
  with:
    php-version: '8.3'
  env:
    debug: true
  • Added support for cached builds for PHP 8.3, PHP 8.4, and zts builds of all versions of PHP 5.6 and newer on Ubuntu GitHub Hosted environments. This should reduce the time it takes to set up these PHP versions.

  • Added swoole to the builds cache for GitHub-hosted environments for PHP 7.2 and newer.

- name: Setup PHP 8.3
  uses: shivammathur/setup-php@v2
  with:
    php-version: '8.3'
    extensions: swoole
  • Added PHP 8.3 and PHP 8.4 to the extension lists in the wiki. (#787).

  • PHP 8.0 is now marked as End of life and PHP 8.1 is now marked as Security fixes only in README.
    See PHP Support in README.

  • Fixed support for Blackfire extension. The action now disabled Xdebug and pcov extensions by default when blackfire is specified in extensions input.

- name: Setup PHP with blackfire extension
  uses: shivammathur/setup-php@v2
  with:
    php-version: '8.3'
    extensions: blackfire
  • Fixed support for grpc_php_plugin when installed along with protoc on macOS.
- name: Setup PHP
  uses: shivammathur/setup-php@v2
  with:
    php-version: '8.3'
    tools: protoc, grpc_php_plugin
  • Fixed support for geos extension on PHP 8.3.
- name: Setup PHP with geos extension
  uses: shivammathur/setup-php@v2
  with:
    php-version: '8.3'
    extensions: geos
  • Fixed support for event extension on macOS to use openssl@3 formula.
- name: Setup PHP with geos extension
  uses: shivammathur/setup-php@v2
  with:
    php-version: '8.3'
    extensions: event
  • Update Node.js dependencies.

Merged Pull Requests

For the complete list of changes, please refer to the Full Changelog

Follow for updates

setup-php reddit setup-php twitter setup-php status

2.27.1

07 Nov 09:29
a36e1e5
Compare
Choose a tag to compare

Changelog

  • Fixed updating PHP dependencies after formulae in homebrew/core tap have been sharded into directories with prefixes. (#780)

  • Update actions/setup-node from v3 to v4 in the node workflow.

  • Update Node.js dependencies.

For the complete list of changes, please refer to the Full Changelog

Follow for updates

setup-php reddit setup-php twitter setup-php status

2.27.0

01 Nov 21:18
81cd5ae
Compare
Choose a tag to compare

Changelog

  • Tools box and php-scoper can now be installed easily using the tools input. (#776)
- name: Setup PHP
  uses: shivammathur/setup-php@v2
  with:
    php-version: '8.2'
    tools: box, php-scoper
  • Added support for macOS 14.x Sonoma and dropped support for macOS 11.x Big Sur following a three-year support cycle that Apple follows for macOS.

  • We now set keepAlive in https agent to false in fetch.ts. After Node 19 it is set to true by default. This prevented the node process from exiting until timeout after the action run was completed. (#773, #777) - Ref

  • Fixed support for couchbase extension for PHP 7.4.

- name: Setup PHP
  uses: shivammathur/setup-php@v2
  with:
    php-version: '7.4'
    extensions: couchbase
  • Fixed a warning when find was run without checking if the path exists on macOS.

  • Fixed checking for existing PHP installations on macOS on self-hosted environments.

  • Fixed adding tools in case /usr/local/bin directory was missing on self-hosted environments.

  • Bumped Node.js dependencies.

Merged Pull Requests

New Contributors

Full Changelog

For the complete list of changes, please refer to the Full Changelog: 2.26.0...2.27.0.

Thanks @tillkruss for the sponsorship ❤️

Follow for updates

setup-php reddit setup-php twitter setup-php status