Skip to content
Browse files

nvidia_x11_legacy173: Use kernel.dev instead of kernelDev

Signed-off-by: Shea Levy <shea@shealevy.com>
  • Loading branch information...
1 parent e4bc4a4 commit 596858c135ef978573a5ecebc3b29e1f4d714f30 @shlevy committed
View
5 pkgs/os-specific/linux/nvidia-x11/builder-legacy.sh
@@ -29,11 +29,12 @@ buildPhase() {
# Create the module.
kernelVersion=$(cd $kernel/lib/modules && ls)
- sysSrc=$(echo $kernel/lib/modules/$kernelVersion/build/)
+ sysSrc=$(echo $kernel/lib/modules/$kernelVersion/source/)
+ sysOut=$(echo $kernel/lib/modules/$kernelVersion/build/)
unset src # used by the nv makefile
# Hack necessary to compile on 2.6.28.
export NIX_CFLAGS_COMPILE="$NIX_CFLAGS_COMPILE -I$sysSrc/include/asm/mach-default"
- make SYSSRC=$sysSrc module
+ make SYSSRC=$sysSrc SYSOUT=$sysOut module
cd ../../..
fi
}
View
6 pkgs/os-specific/linux/nvidia-x11/legacy173.nix
@@ -1,4 +1,4 @@
-{stdenv, fetchurl, kernelDev, xlibs, zlib, gtk, atk, pango, glib, gdk_pixbuf}:
+{stdenv, fetchurl, kernel, xlibs, zlib, gtk, atk, pango, glib, gdk_pixbuf}:
let
@@ -7,7 +7,7 @@ let
in
stdenv.mkDerivation {
- name = "nvidia-x11-${versionNumber}-${kernelDev.version}";
+ name = "nvidia-x11-${versionNumber}-${kernel.version}";
builder = ./builder-legacy.sh;
@@ -24,7 +24,7 @@ stdenv.mkDerivation {
}
else throw "nvidia-x11 does not support platform ${stdenv.system}";
- kernel = kernelDev;
+ kernel = kernel.dev;
inherit versionNumber;

0 comments on commit 596858c

Please sign in to comment.
Something went wrong with that request. Please try again.