Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Comparing changes

Choose two branches to see what's changed or to start a new pull request. If you need to, you can also compare across forks.

Open a pull request

Create a new pull request by comparing changes across two branches. If you need to, you can also compare across forks.
base fork: shock/wdd-ruby-ext
base: daeb6393bf
...
head fork: shock/wdd-ruby-ext
compare: 08dfa7e610
Checking mergeability… Don't worry, you can still create the pull request.
  • 3 commits
  • 5 files changed
  • 0 commit comments
  • 1 contributor
View
7 Gemfile
@@ -1,10 +1,3 @@
source :gemcutter, :github
gem 'wdd-ruby-ext', :path=>"."
-gem "nokogiri", "~> 1.4.1"
-gem "eventmachine", "~> 0.12.10"
-gem "jeweler"
-
-group :development, :test do
- gem 'rspec', '~> 1.3'
-end
View
10 Gemfile.lock
@@ -1,8 +1,11 @@
PATH
remote: .
specs:
- wdd-ruby-ext (0.4.4)
+ wdd-ruby-ext (0.5.0)
eventmachine (~> 0.12.10)
+ eventmachine (~> 0.12.10)
+ jeweler
+ nokogiri (~> 1.4.1)
nokogiri (~> 1.4.1)
wdd-ruby-ext
@@ -21,14 +24,9 @@ GEM
rake (0.8.7)
rdoc (3.12)
json (~> 1.4)
- rspec (1.3.2)
PLATFORMS
ruby
DEPENDENCIES
- eventmachine (~> 0.12.10)
- jeweler
- nokogiri (~> 1.4.1)
- rspec (~> 1.3)
wdd-ruby-ext!
View
2  Rakefile
@@ -10,7 +10,7 @@ begin
gem.email = "github@wdoughty.net"
gem.homepage = "http://github.com/shock/wdd-ruby-ext"
gem.authors = ["shock"]
- gem.add_development_dependency "rspec", ">= 1.2.9"
+ gem.add_development_dependency "rspec", '~> 1.3'
gem.add_dependency "nokogiri", "~> 1.4.1"
gem.add_dependency "eventmachine", "~> 0.12.10"
# gem is a Gem::Specification... see http://www.rubygems.org/read/chapter/20 for additional settings
View
2  VERSION
@@ -1 +1 @@
-0.5.0
+0.5.1
View
14 wdd-ruby-ext.gemspec
@@ -5,7 +5,7 @@
Gem::Specification.new do |s|
s.name = %q{wdd-ruby-ext}
- s.version = "0.5.0"
+ s.version = "0.5.1"
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
s.authors = ["shock"]
@@ -64,30 +64,18 @@ Gem::Specification.new do |s|
if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
s.add_runtime_dependency(%q<wdd-ruby-ext>, [">= 0"])
- s.add_runtime_dependency(%q<nokogiri>, ["~> 1.4.1"])
- s.add_runtime_dependency(%q<eventmachine>, ["~> 0.12.10"])
- s.add_runtime_dependency(%q<jeweler>, [">= 0"])
s.add_development_dependency(%q<rspec>, ["~> 1.3"])
- s.add_development_dependency(%q<rspec>, [">= 1.2.9"])
s.add_runtime_dependency(%q<nokogiri>, ["~> 1.4.1"])
s.add_runtime_dependency(%q<eventmachine>, ["~> 0.12.10"])
else
s.add_dependency(%q<wdd-ruby-ext>, [">= 0"])
- s.add_dependency(%q<nokogiri>, ["~> 1.4.1"])
- s.add_dependency(%q<eventmachine>, ["~> 0.12.10"])
- s.add_dependency(%q<jeweler>, [">= 0"])
s.add_dependency(%q<rspec>, ["~> 1.3"])
- s.add_dependency(%q<rspec>, [">= 1.2.9"])
s.add_dependency(%q<nokogiri>, ["~> 1.4.1"])
s.add_dependency(%q<eventmachine>, ["~> 0.12.10"])
end
else
s.add_dependency(%q<wdd-ruby-ext>, [">= 0"])
- s.add_dependency(%q<nokogiri>, ["~> 1.4.1"])
- s.add_dependency(%q<eventmachine>, ["~> 0.12.10"])
- s.add_dependency(%q<jeweler>, [">= 0"])
s.add_dependency(%q<rspec>, ["~> 1.3"])
- s.add_dependency(%q<rspec>, [">= 1.2.9"])
s.add_dependency(%q<nokogiri>, ["~> 1.4.1"])
s.add_dependency(%q<eventmachine>, ["~> 0.12.10"])
end

No commit comments for this range

Something went wrong with that request. Please try again.