remote_debugger.rb and require 'byebug/core' #231

Closed
passenger94 opened this Issue Mar 29, 2016 · 2 comments

Comments

Projects
None yet
2 participants
@passenger94
Contributor

passenger94 commented Mar 29, 2016

in order to make the remote byebug debugger work i had to
require 'byebug/core' instead of just require 'byebug'
(linux, latest Shoes, byebug 8.2.1 & 8.2.2)

don't know if it's the best way to resolve the problem (no server, no connection)
found some clue over the internet, don't remember where ...

@ccoupe

This comment has been minimized.

Show comment
Hide comment
@ccoupe

ccoupe Mar 29, 2016

Contributor

Which version of byebug? Shoes is shipping with bybug-8.2.1 which is a lot of numbers more than we first had. I also note that I've not installed in my tight shoes which means I haven't used it. This might be a feature that would benefit from a few automated tests for shoes integration. I think byebug itself does have a test suite.

Contributor

ccoupe commented Mar 29, 2016

Which version of byebug? Shoes is shipping with bybug-8.2.1 which is a lot of numbers more than we first had. I also note that I've not installed in my tight shoes which means I haven't used it. This might be a feature that would benefit from a few automated tests for shoes integration. I think byebug itself does have a test suite.

@passenger94

This comment has been minimized.

Show comment
Hide comment
@passenger94

passenger94 Mar 30, 2016

Contributor

linux, latest Shoes, byebug 8.2.1 & 8.2.2

😎

Contributor

passenger94 commented Mar 30, 2016

linux, latest Shoes, byebug 8.2.1 & 8.2.2

😎

@ccoupe ccoupe added this to the 3.3.1 milestone Apr 5, 2016

@ccoupe ccoupe closed this in bd8f7b9 Apr 5, 2016

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment