Permalink
Browse files

Update documentation, fix broken link

  • Loading branch information...
1 parent ad2f785 commit b8c8680ae482fbf7ddc53ca2a465fa06a6a5a2c9 @shred committed Nov 23, 2016
Showing with 7 additions and 29 deletions.
  1. +6 −28 src/site/markdown/android.md.vm
  2. +1 −1 src/site/markdown/index.md.vm
@@ -3,20 +3,18 @@ How to use flattr4j on Android devices
For running _flattr4j_ v2 on Android, at least Android 3.0 "Honeycomb" is needed. Lower API levels do not work because the Flattr server makes use of SNI. I recommend to use at least _flattr4j_ v2.13, especially if you run into HTTPS certificate issues.
+Usage
+-----
+
+The flattr4j core API can be used without restrictions on Android, including `FlattrService` and `FlattrAuthenticator`.
+
Requirements
------------
-In order to use flattr4j on Android, you need to copy the `flattr4j-core.jar` to your project's `libs` directory.
-
-flattr4j also needs the _json.org_ library. However, it is already provided by Android and does not need to be installed separately. So, you only need to copy the `flattr4j-core.jar` to your project.
+flattr4j depends on the _json.org_ reference library. However, it is already provided by Android and does not need to be installed separately.
Since flattr4j connects to the Flattr API via HTTP, your application needs `INTERNET` permission to run.
-Usage
------
-
-The flattr4j core API can be used without restrictions on Android, including `FlattrService` and `FlattrAuthenticator`.
-
Gradle
------
@@ -31,23 +29,3 @@ dependencies {
}
}
```
-
-Maven
------
-
-If you are using Maven for Android development, add these dependency lines:
-
-```xml
-<dependency>
- <groupId>${project.groupId}</groupId>
- <artifactId>${project.artifactId}-core</artifactId>
- <version>${project.version}</version>
- <scope>compile</scope>
- <exclusions>
- <exclusion>
- <groupId>org.json</groupId>
- <artifactId>json</artifactId>
- </exclusion>
- </exclusions>
-</dependency>
-```
@@ -27,6 +27,6 @@ Requirements
_flattr4j_ needs at least Java 1.6 or Android API level 11 (earlier levels do not work because they do not support SNI).
-_flattr4j_ version 2 requires [json.org](http://www.json.org/java/index.html). If you use Maven, the dependency is loaded automatically. Android API provides it, so `flattr4j-core` does not need additional libraries on Android devices.
+_flattr4j_ version 2 requires the [json.org reference library](https://github.com/stleary/JSON-java). If you use Maven, the dependency is loaded automatically. Android API provides it, so `flattr4j-core` does not need additional libraries on Android devices.
Up to version 2.11, _flattr4j_ also required [Apache HttpComponents 4](http://hc.apache.org/).

0 comments on commit b8c8680

Please sign in to comment.