Permalink
Browse files

add files

  • Loading branch information...
1 parent 0b70f90 commit 02121849cd8332df64082363bd6f37af217ed258 @shvets committed May 6, 2011
Showing with 104 additions and 74 deletions.
  1. +24 −1 .idea/haml-sass-converters.iml
  2. +3 −0 .idea/misc.xml
  3. +57 −69 .idea/workspace.xml
  4. +5 −2 Gemfile
  5. +9 −0 Gemfile.lock
  6. +1 −1 README
  7. +1 −1 lib/converters.rb
  8. +4 −0 spec
@@ -45,19 +45,39 @@
</requirement>
<requirement>
<requirement>
+ <dependency name="rparsec" version="1.0" bound="EQUAL" git="false" path="false" doRequire="true" />
+ </requirement>
+ <source from="Gemfile" />
+ </requirement>
+ <requirement>
+ <requirement>
+ <dependency name="ruby2ruby" version="1.2.5" bound="EQUAL" git="false" path="false" doRequire="true" />
+ </requirement>
+ <source from="Gemfile" />
+ </requirement>
+ <requirement>
+ <requirement>
<dependency name="ruby_parser" version="2.0.5" bound="EQUAL" git="false" path="false" doRequire="true" />
</requirement>
<source from="Gemfile" />
</requirement>
<requirement>
<requirement>
+ <dependency name="sexp" version="0.2.1" bound="EQUAL" git="false" path="false" doRequire="true" />
+ </requirement>
+ <source from="Gemfile" />
+ </requirement>
+ <requirement>
+ <requirement>
<dependency name="sexp_processor" version="3.0.5" bound="EQUAL" git="false" path="false" doRequire="true" />
</requirement>
<source from="Gemfile" />
</requirement>
</component>
<component name="NewModuleRootManager">
- <content url="file://$MODULE_DIR$" />
+ <content url="file://$MODULE_DIR$">
+ <excludeFolder url="file://$MODULE_DIR$/.bundle" />
+ </content>
<orderEntry type="inheritedJdk" />
<orderEntry type="sourceFolder" forTests="false" />
<orderEntry type="library" scope="PROVIDED" name="[gem] rake (v0.8.7, /Users/oshvets/.rvm/gems/jruby-1.5.6@global/gems/rake-0.8.7)" level="application" />
@@ -75,6 +95,9 @@
<orderEntry type="library" scope="PROVIDED" name="[gem] bouncy-castle-java (v1.5.0145.2, /Users/oshvets/.rvm/gems/jruby-1.5.6@haml-sass-converters/gems/bouncy-castle-java-1.5.0145.2)" level="application" />
<orderEntry type="library" scope="PROVIDED" name="[gem] git (v1.2.5, /Users/oshvets/.rvm/gems/jruby-1.5.6@haml-sass-converters/gems/git-1.2.5)" level="application" />
<orderEntry type="library" scope="PROVIDED" name="[gem] abstract (v1.0.0, /Users/oshvets/.rvm/gems/jruby-1.5.6@haml-sass-converters/gems/abstract-1.0.0)" level="application" />
+ <orderEntry type="library" scope="PROVIDED" name="[gem] sexp (v0.2.1, /Users/oshvets/.rvm/gems/jruby-1.5.6@haml-sass-converters/gems/sexp-0.2.1)" level="application" />
+ <orderEntry type="library" scope="PROVIDED" name="[gem] ruby2ruby (v1.2.5, /Users/oshvets/.rvm/gems/jruby-1.5.6@haml-sass-converters/gems/ruby2ruby-1.2.5)" level="application" />
+ <orderEntry type="library" scope="PROVIDED" name="[gem] rparsec (v1.0, /Users/oshvets/.rvm/gems/jruby-1.5.6@haml-sass-converters/gems/rparsec-1.0)" level="application" />
</component>
</module>
View
@@ -3,6 +3,9 @@
<component name="DependencyValidationManager">
<option name="SKIP_IMPORT_STATEMENTS" value="false" />
</component>
+ <component name="ProjectResources">
+ <default-html-doctype>http://www.w3.org/1999/xhtml</default-html-doctype>
+ </component>
<component name="ProjectRootManager" version="2" project-jdk-name="JRuby SDK 1.5.6-p249 [haml-sass-converters]" project-jdk-type="JRUBY_SDK" />
</project>
View

Large diffs are not rendered by default.

Oops, something went wrong.
View
@@ -2,10 +2,13 @@ source "http://rubygems.org"
gem "haml", "3.0.24"
gem "hpricot", "0.8.3"
-gem "abstract", "1.0.0"
gem "erubis", "2.6.6"
-gem "sexp_processor", "3.0.5"
gem "ruby_parser", "2.0.5"
+gem "ruby2ruby", "1.2.5"
+gem "sexp_processor", "3.0.5"
+gem "sexp", "0.2.1"
+gem "rparsec", "1.0"
+gem "abstract", "1.0.0"
group :development do
gem "jeweler"
View
@@ -16,8 +16,14 @@ GEM
jruby-openssl (0.7.3)
bouncy-castle-java
rake (0.8.7)
+ rparsec (1.0)
+ ruby2ruby (1.2.5)
+ ruby_parser (~> 2.0)
+ sexp_processor (~> 3.0)
ruby_parser (2.0.5)
sexp_processor (~> 3.0)
+ sexp (0.2.1)
+ rparsec (>= 1.0)
sexp_processor (3.0.5)
PLATFORMS
@@ -31,5 +37,8 @@ DEPENDENCIES
hpricot (= 0.8.3)
jeweler
jruby-openssl
+ rparsec (= 1.0)
+ ruby2ruby (= 1.2.5)
ruby_parser (= 2.0.5)
+ sexp (= 0.2.1)
sexp_processor (= 3.0.5)
View
2 README
@@ -4,7 +4,7 @@
1. Install jruby:
-> rvm install jruby-1.5.6
+> rvm install jruby-1.6.0
We are not going to use this version of JRuby - RubyMine has already bundled version of it.
We need to install it in order to collect all required for this plugin gems.
View
@@ -1,7 +1,7 @@
include Java
def load_required_gems
- jruby_home = "#{ENV['HOME']}/.rvm/gems/jruby-1.5.6@haml-sass-converters"
+ jruby_home = "#{ENV['HOME']}/.rvm/gems/jruby-1.6.0@haml-sass-converters"
$: << "#{jruby_home}/gems"
View
4 spec
@@ -0,0 +1,4 @@
+Script started on Thu Mar 24 09:45:59 2011
+script: /Users/oshvets/work/ui/src/vendor/plugins/triton/spec/controllers/triton/confirm_controller_spec.rb: Permission denied
+
+Script done on Thu Mar 24 09:45:59 2011

0 comments on commit 0212184

Please sign in to comment.