Skip to content
Packagist Integration for Shopware
Branch: master
Clone or download
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Type Name Latest commit message Commit time
Failed to load latest commit information.
Bundle/ComposerBundle
Controllers/Backend
Resources
Subscriber
.gitignore
README.md
ShyimPluginManager.php
composer.json
composer.lock
plugin.xml

README.md

Packagist Pluginmanager Integration for Shopware

Required Minimum Shopware Version 5.3

This integration is experimental. If you found bugs feel free to report :)

Installation

Git Version

  • Checkout Plugin in /custom/plugins/ShyimPluginManager
  • Change to Directory and run composer install to install the dependencies
  • Install the Plugin with the Plugin Manager

How to add Plugins?

  • Add a composer.json file to your Repository. Example File
  • Publish our plugin to packagist.org

Composer-Types

Type Default Plugin Location
shopware-backend-plugin engine/Shopware/Plugins/Local/Backend/
shopware-core-plugin engine/Shopware/Plugins/Local/Core/
shopware-frontend-plugin engine/Shopware/Plugins/Local/Frontend/
shopware-plugin custom/plugins/
shopware-frontend-theme themes/Frontend/

Images

PluginManager

You can’t perform that action at this time.