Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Added svgwrite to requirements

  • Loading branch information...
commit 34b4a8204427a736143fbdabcbd1c816b948a8d3 1 parent b66f473
@brooksryba brooksryba authored
Showing with 1 addition and 1 deletion.
  1. +1 −1  setup.py
View
2  setup.py
@@ -25,7 +25,7 @@
license='BSD',
packages = find_packages(exclude=['ez_setup']),
zip_safe = False,
- requires=['cv2','cv', 'numpy', 'scipy', 'pygame', 'pil'],
+ requires=['cv2','cv', 'numpy', 'scipy', 'pygame', 'pil', 'svgwrite'],
package_data = { #DO NOT REMOVE, NEEDED TO LOAD INLINE FILES i = Image('simplecv')
'SimpleCV': ['sampleimages/*',
'Features/HaarCascades/*',

1 comment on commit 34b4a82

@tony72

So if the requirement for svgwrite was added why the hell is the package not installed with everything else, or the instructions for installation not updated to include how to install svgwrite. Update the installation instructions, and make sure you inform people that they now need svgwrite for setup.py to run. I can't even find svgwrite to get it installed on my Raspberry PI. You guys just broke a really good python library for accessing OpenCV. You need to fix this right now, not in a couple months when you get around to it.

Please sign in to comment.
Something went wrong with that request. Please try again.