Permalink
Browse files

Udpate Gems.

  • Loading branch information...
1 parent b9deaf6 commit 050008fdd2525475c5ee3de65c066b1ea20601bc @netzpirat netzpirat committed Jan 9, 2012
Showing with 15 additions and 13 deletions.
  1. +15 −13 Gemfile
View
28 Gemfile
@@ -1,28 +1,30 @@
-source 'http://rubygems.org'
+source :rubygems
-# Specify your gem's dependencies in guard-coffee-script.gemspec
gemspec
gem 'rake'
-require 'rbconfig'
+platform :ruby do
+ gem 'rb-readline'
+end
platform :ruby_18 do
gem 'json'
end
-if RbConfig::CONFIG['target_os'] =~ /darwin/i
- gem 'rb-fsevent', '>= 0.4.0'
- gem 'growl', '~> 1.0.3'
-end
-if RbConfig::CONFIG['target_os'] =~ /linux/i
- gem 'rb-inotify', '>= 0.8.4'
- gem 'libnotify', '~> 0.3.0'
-end
-
# The JS runtime is needed because ExecJS searches one when the module is loaded.
# This breaks travis builds even when the compiler is stubbed.
-
platform :jruby do
gem 'therubyrhino'
end
+
+require 'rbconfig'
+
+if RbConfig::CONFIG['target_os'] =~ /darwin/i
+ gem 'ruby_gntp', '~> 0.3.4', :require => false
+elsif RbConfig::CONFIG['target_os'] =~ /linux/i
+ gem 'libnotify', '~> 0.7.1', :require => false
+elsif RbConfig::CONFIG['target_os'] =~ /mswin|mingw/i
+ gem 'win32console', :require => false
+ gem 'rb-notifu', '>= 0.0.4', :require => false
+end

0 comments on commit 050008f

Please sign in to comment.