SS3 dev/build error #28

Closed
kumosal opened this Issue May 2, 2012 · 8 comments

Projects

None yet

5 participants

@kumosal

I'm trying to install the module in Silverstripe v3 beta2, but I get the following error when I run dev/build:

[Strict Notice] Declaration of TrackBackDecorator::extraStatics() should be compatible with that of DataExtension::extraStatics()
GET /dev/build?flush=1

Line 5 in /home/winopres/public_html/blog/code/TrackBackDecorator.php
Source
150         return new SS_HTTPResponse($response, $statusCode);
151     }
152 }
153 
154 ?>

any help?

@cbarberis
SilverStripe Ltd. member
@kumosal

ok I did, thanks

@asecondwill

I get the same result. This is an issue - module not compatible with ss3. Is this the right place to report issues?

[Strict Notice] Declaration of TrackBackDecorator::extraStatics() should be compatible with that of DataExtension::extraStatics()

GET /dev/build?flush=1

Line 5 in /Users/willbarker/Sites/ss3/widgets/blog/code/TrackBackDecorator.php

Source

150         return new SS_HTTPResponse($response, $statusCode);
151     }
152 }
153 
154 ?>
Trace

require_once(/Users/willbarker/Sites/ss3/widgets/blog/code/TrackBackDecorator.php) 
ClassLoader.php:82
SS_ClassLoader->loadClass(TrackBackDecorator) 
spl_autoload_call(TrackBackDecorator) 
call_user_func(Array,BlogEntry,TrackBackDecorator,Array) 
Object.php:561
Object->__construct() 
DataObject.php:373
DataObject->__construct(,1) 
ReflectionClass->newInstanceArgs(Array) 
Object.php:243
Object::strong_create(BlogEntry,,1) 
Core.php:367
singleton(BlogEntry) 
DatabaseAdmin.php:203
DatabaseAdmin->doBuild(,1) 
DatabaseAdmin.php:102
DatabaseAdmin->build(SS_HTTPRequest) 
Controller.php:195
Controller->handleAction(SS_HTTPRequest) 
RequestHandler.php:168
RequestHandler->handleRequest(SS_HTTPRequest,DataModel) 
Controller.php:149
Controller->handleRequest(SS_HTTPRequest,DataModel) 
DevelopmentAdmin.php:141
DevelopmentAdmin->build(SS_HTTPRequest) 
RequestHandler.php:168
RequestHandler->handleRequest(SS_HTTPRequest,DataModel) 
Controller.php:149
Controller->handleRequest(SS_HTTPRequest,DataModel) 
Director.php:257
Director::handleRequest(SS_HTTPRequest,Session,DataModel) 
Director.php:99
Director::direct(/dev/build,DataModel) 
main.php:128
@cbarberis
SilverStripe Ltd. member
@asecondwill

Hi, Cool thanks. I commented out dev but there where further errors. To be expected with such a big upgrade. Thanks for updating the ticket.

@kmayo-ss

Looking at this issue now

@kmayo-ss

This module is not SS3 compliant also in the master branch of the blog module the file TrackBackDecorator.php has now been removed.
I have installed the blog module on 3.1 and have confirmed the error is now resolved

@wilr wilr closed this Aug 9, 2013
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment