Skip to content
Browse files

MINOR Skipping test when PHP Version is lower than 5.3.2

ReflectionMethod#setAccessible was released in PHP Version 5.3.2
  • Loading branch information...
1 parent 51a81bb commit a3a50b7b6f2f3a3b3e18e828761204760a541a23 @stojg stojg committed Oct 22, 2011
Showing with 4 additions and 0 deletions.
  1. +4 −0 tests/model/SiteTreeTest.php
View
4 tests/model/SiteTreeTest.php
@@ -829,6 +829,10 @@ function testAllowedChildrenValidation() {
}
function testClassDropdown() {
+ if(version_compare(PHP_VERSION, '5.3.2', '<')){
+ // @link http://www.php.net/manual/en/reflectionmethod.setaccessible.php
+ $this->markTestSkipped('Need PHP 5.3.2 to run this test.');
+ }
$sitetree = new SiteTree();
$method = new ReflectionMethod($sitetree, 'getClassDropdown');
$method->setAccessible(true);

0 comments on commit a3a50b7

Please sign in to comment.
Something went wrong with that request. Please try again.