Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

Mistakes with written _t() function in 2 templates #1025

Closed
zrii opened this Issue Jun 5, 2014 · 2 comments

Comments

Projects
None yet
3 participants

zrii commented Jun 5, 2014

There are 2 templates in CMS Includes:
Install_deleteinstallfiles.ss && Install_successfullyinstalled.ss
that have a syntax error with the _t() function.

Example: <%t ContentController.UnableDeleteInstall "Unable to delete installation files. Please delete the files below manually" %>

Had problems with i18nTextCollectorTask because of this. Simple solution is to fix the syntax of _t() function in the 2 templates.

Contributor

kmayo-ss commented Aug 8, 2014

I tried running the i18nTextCollectorTask on a fresh install from the command line and could not replicate the issue.
Can you confirm if this is still an issue and what version you are using.
Also looking at the current documentation the translate function should be <%t params %> in the template

Usage in Template Files

The preferred template syntax has changed somewhat since version 2.x.

In .ss template files, instead of _t(params) the syntax <%t params %> is used. The syntax for passing >parameters to the function is quite different to the PHP version of the function.

Contributor

tractorcow commented Nov 20, 2014

Issue can't be replicated, so I'm going to close this if that's ok. :)

If you still have issues, make sure you're using an updated version of the framework alongside your cms module.

@tractorcow tractorcow closed this Nov 20, 2014

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment